• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Question Better ways to add a 2nd NVME to a single-slot mainboard?

bigpow

Platinum Member
Dec 10, 2000
2,372
2
81
Mainboard: Asrock X570 Phantom Gaming-ITX/TB3
1x PCI express & 1x NVME slots.

Current configuration:
Internal:
1x Corsair Force MP500 1TB is connected to the mainboard NVME slot.
External:
1x Adata XPG SX8200 2TB, inside a Sabrent (EC-NVME) NVME to USB3 external enclosure, via USB-C/TB3 (mainboard IO)
and
1x Samsung T5 1TB connected to a USB3.2 port

Issues:
1. Speed is bus limited, as observed in Dskmark scores below:
- MP5000 = ~5000
- SX8200 = ~1000
- T5 = ~300
2. (had) Severe stuttering/lagging issues while using the external USB NVME with USB-C port. Seems to be mitigated by BIOS settings (disable some AMD PBS & CBS options) & installing Thunderbolt driver from Lenovo (over ASRock)


SATA3 should be a better option for the 2nd NVME drive, but I'm having difficulty finding the right set of components for it. Most of the adapters on AMZN are for converting to U.2 or inly for M.2 non NVME.

Not to mention that I'd need a special SATA cable that's either very thin & flexible, or, some kind of SATA port angle changer (ports are blocked by PSU)


Thanks in advance
 

Billy Tallis

Senior member
Aug 4, 2015
255
113
116
SATA3 should be a better option for the 2nd NVME drive, but I'm having difficulty finding the right set of components for it. Most of the adapters on AMZN are for converting to U.2 or inly for M.2 non NVME.
You can't attach a NVMe drive to SATA ports. SATA is not PCIe.

When PCIe SSDs first started to appear, there was the short-lived SATA Express standard that allowed motherboards to bond together two SATA connectors plus an extra piece into a PCIe x2 connection. A bunch of motherboards supported this because Intel's chipsets provide numerous IO lanes that can be configured to operate as SATA or PCIe or USB lanes depending on what kind of ports the motherboard vendor wants to provide. This configurability allowed motherboards to provide dual-role ports for SATA Express with almost no extra cost.

SATA Express is dead. Approximately zero products were ever released that you could attach to SATA Express ports. The SATA ports on modern motherboards are regular SATA ports, not SATA Express ports; they're missing the extra third piece of the connector and the firmware support necessary for reconfiguring the chipset or SoC to operate those lanes as PCIe rather than SATA. The PCIe SSD market moved on to solutions that allow four lanes of PCIe: U.2 and M.2.

Your ITX motherboard is small and doesn't have many expansion slots. This is the downside of choosing a small form factor. The best-performing connector you have left for adding a second SSD is the Thunderbolt port. Thunderbolt enclosures for NVMe SSDs are quite a bit more expensive than USB to NVMe enclosures, but they are simpler, faster and more reliable. If a USB to NVMe enclosure isn't fast enough for you, Thunderbolt is your only real option left.

SATA SSDs would not give you as much raw throughput as a NVMe SSD, but would work reliably without any of the pitfalls of USB to NVMe converters.
 

Shmee

Memory and Storage, Graphics Cards
Super Moderator
Sep 13, 2008
4,946
785
126
I think there was supposed to be some SATA Express RAID enclosure that was going to come out from Asus or something, that would allow multiple SATA SSDs inside. Idk if it was ever released, or what.
 

bigpow

Platinum Member
Dec 10, 2000
2,372
2
81
I bought an Orico TB3 NVME enclosure that claims to get up to 40Gbps to try. Can't hurt. Yes, SFF compromises.
At this point, I'm at the mercy of a much slower drive, or, micro stuttering. Both making my new machine feel like a
 

Muadib

Lifer
May 30, 2000
16,604
385
126
I bought an Orico TB3 NVME enclosure that claims to get up to 40Gbps to try. Can't hurt. Yes, SFF compromises.
At this point, I'm at the mercy of a much slower drive, or, micro stuttering. Both making my new machine feel like a
Are you using Windows or a Mac? Most Windows computers don't have Thunderbolt 3 ports, so no way will they see 40Gbps.
 

bigpow

Platinum Member
Dec 10, 2000
2,372
2
81
Mainboard is a unicorn Asrock itx with X570 & TB3.

TB3 works with windows.
Been that way for a while..
My old razer blade stealth notebook has one and I've been using that setup with egpu+gtx1080 and EC-NVME+samsung 970p and T5 drives for steam for years. No issues.
The same setup also works well with Ubuntu (dual boot, my dev platform).


Mod: can you please close this?
It's too similar to:






PS:
The enclosure bought is probably gonna be unused. Pulled the trigger too fast.
This asrock is proven to be finicky, it only works well without any external drives connected, regardless of ports (tb3, usb3 10g, usb3 5g).
Intermittent sluggishness, stuttering, lagging, everything: mouse, audio, etc.
Same drives work fine with old setup.

And yet, it passes tests like memtest, prime95, cinebench, unigine, etc.
Ugh.. obviously something is very wrong!

Bought a Gigabyte mobo to get a 2nd opinion.
 

ASK THE COMMUNITY

TRENDING THREADS