ATi Catalyst 2.5 Drivers

Bovinicus

Diamond Member
Aug 8, 2001
3,145
0
0
The latest drivers from ATi are available for download off their website. I just installed them and they seem to be working fine. In fact, Neverwinter Nights seems to be running a little smoother. I am very pleased with ATi as of late. Oh yeah, and VSync can be Always On now. M00T!
 

Lizardman

Golden Member
Jul 23, 2001
1,990
0
0
again with the smiley face an no comment.. eh eplebnista.

I will just stick with cat 2.2 as they have given me no problems so far on my r8500
 

CurtCold

Golden Member
Aug 15, 2002
1,547
0
0
Installed them, seems to be better on the 8500, enabled fast write with rage3d, and bios, helped out the smoothness of games. (didn't realize it wasn't turned on)

No issues with the 2.5's here.
 

Bovinicus

Diamond Member
Aug 8, 2001
3,145
0
0
Lizardman, I would highly suggest upgrading to these drivers. You are a few updates behind, and there have definitely been some quality, performance, compatbility, and useability improvement in the driver set. I am running the 2.5s now and have yet to come across problems.
 

stryder2929

Senior member
Oct 23, 2002
324
0
0
i'll get em for my 9700pro tonight :)

quick question, do i just update or should i remove the old drivers (2.4 i guess) first?

also another thing

when i enabled fastwrite and agp8x before, it gave me performance issues with unreal tournament 2k3

will i still get those issues with the updated drivers or is it worth a shot?
 

mamisano

Platinum Member
Mar 12, 2000
2,045
0
76
Originally posted by: stryder2929
i'll get em for my 9700pro tonight :)

quick question, do i just update or should i remove the old drivers (2.4 i guess) first?

also another thing

when i enabled fastwrite and agp8x before, it gave me performance issues with unreal tournament 2k3

will i still get those issues with the updated drivers or is it worth a shot?
Remove old Display Drivers and Control Panel --> Reboot
Install Display Drivers --> Reboot
Install Control Panel --> Reboot
 

Spicedaddy

Platinum Member
Apr 18, 2002
2,299
73
91
Originally posted by: mamisano
Originally posted by: stryder2929
i'll get em for my 9700pro tonight :)

quick question, do i just update or should i remove the old drivers (2.4 i guess) first?

also another thing

when i enabled fastwrite and agp8x before, it gave me performance issues with unreal tournament 2k3

will i still get those issues with the updated drivers or is it worth a shot?
Remove old Display Drivers and Control Panel --> Reboot
Install Display Drivers --> Reboot
Install Control Panel --> Reboot
Installing the new Drivers and CP without rebooting in between also works fine.
 

Chadder007

Diamond Member
Oct 10, 1999
7,560
0
0
I uninstalled, cleared the registry and all but I have problems with RTCW....the face of the guy on the menu screen is screwed up. Half of his head is totally gone. Also in UT2k3 demo, you can still see through the floor and ceilings.
 

wnied

Diamond Member
Oct 10, 1999
4,206
0
76
Me likey the new 2.5 cats. Makes my DoD experience 100x better for my Ati Radeon VE.

~wnied~
 

Thor86

Diamond Member
May 3, 2001
7,883
4
81
Originally posted by: Chadder007
I uninstalled, cleared the registry and all but I have problems with RTCW....the face of the guy on the menu screen is screwed up. Half of his head is totally gone. Also in UT2k3 demo, you can still see through the floor and ceilings.
You might want to try and re-config these games for video settings.
 

NucEm

Senior member
Jun 13, 2001
242
0
76
I updated the VIA drivers (4.45) then removed older ATi driver before installing ATi's cat. 2.5 driver. The AGP 4X finally works but the Fast Write does not. I'm using an 8500 installed in a ABIT VP6 with a pair of 1GHZ P-3's running XP Pro. (Anyone have any thoughts on the Fast Write?) The new ATi driver seems okay with UT2003. I did lose about 5% with 3Dmark score.

I spoke too soon. The AGP 4X enabled in the bios now causes the system not to boot. Its interesting that when the system has been up and running for a while the AGP 4X can be enabled and things seem to work just fine. If I shut the system down for a few hours the system will post then crash. I wonder if the cap's are starting to fail?
 

lung

Senior member
Apr 17, 2002
236
0
0
It's too bad that they seem to have broken the overlay for videos though. Myself and others have noticed that with the 2.5s your video overlay basically becomes purple and green. Imagine a black and white picture becoming purple and green... Hopefully a new version will be out very soon along with the final of DirectX 9. In games though, I have seen a boost right across the board in all games that I play. :D
 

rbV5

Lifer
Dec 10, 2000
12,632
0
0
Seem to be working great for me, no video overlay problems, fastwries on, 4X AGP enabled fine. WDM drivers check out fine, capture working right. So far so good.
 

lung

Senior member
Apr 17, 2002
236
0
0
My video problems are gone now... Very strange. All that I had really done was shut my comp down at night, and when I started itup the next day, the video was fine..
 

Glitchny

Diamond Member
Sep 4, 2002
5,679
1
0
no problems with overlay here, opnly issue with mine was that i had to go into the xp admin settings and make sure that ATI smart was set to run all the time and on its own... without that my computer said that i didnt even ahve directx installed... was quite scary. but other than taht small issue no problems at all. overlay works fine

glitch
 

DoobieOnline

Golden Member
Jan 12, 2001
1,397
0
0
HOLY CRAP! I just today converted from the Ti4600 to a 9700 Pro and I have to say I'm happy so far. :D My highest 3DMark2001SE score was 14757 with the Ti4600 OC'ed to 315/730 using 40.72 Det's, but with the 9700 Pro at default settings and the Cat 2.5's I just popped 16016! I was really skeptical about giving ATi another go after having some probs in the past with the original Radeon and then an 8500LE, but if things stay this sweet I may hang out for a while. :) UT2003 Benchmark increased a bit, too. From 180/74 @ 1024x768 with the Ti4600 to 211/77 with the 9700 Pro. I'll have to play a few games - RTCW, MOHAA, and some UT2003 to see if everything is kosher but everything is good so far (knock on wood).
 

elkinm

Platinum Member
Jun 9, 2001
2,146
0
71
Do these drivers generaly give a performance bost from previeos versions? I am seing a significant boost in UT2003 on my old radeon I also updated to the latest patch so maybee that is doing some good. The only problem is that after some time of serious game play the system freezes and then recovers at 640x480 4bit collor requiring a restart. Is this from the drivers or could it be the patch?

Thanks
 

ASK THE COMMUNITY