• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Ati 10.4 Preview Driver screen corruption

zod96

Platinum Member
May 28, 2007
2,804
18
81
Anyone getting screen corruption on booting with these drivers?
 

Genx87

Lifer
Apr 8, 2002
41,061
494
126
Sounds like the 10 series has been golden for ATI. I was thinking about upgrading but I will wait.
 

Sylvanas

Diamond Member
Jan 20, 2004
3,752
0
0
It's a pre-release BETA/hotfix driver....you expect there may be problems with a driver like this. The WHQL's come out every month, stick to them for stability. Having said that, that doesn't answer the OPs question- so I hope someone else can chime in with regard to that.
 

Termie

Diamond Member
Aug 17, 2005
7,949
47
91
www.techbuyersguru.com
What kind of screen corruption are you talking about? Can you describe it? With the 10.4 preview, I've had one incident of red vertical lines upon resuming from hibernation, which I also had with the 10.3a drivers. I just restarted and it went away.
 

zod96

Platinum Member
May 28, 2007
2,804
18
81
Its a 100% left to right scrambled splash screen on boot. Once I get to the desktop its fine. Its like the picture is totally out of focus....
 

Imp

Lifer
Feb 8, 2000
18,829
184
106
Haven't tried 10.4, don't think I will. Whatever the latest WHQL certified drivers are, 10.3 or 10.3a, they finally fixed the gray-screen/idle desktop crash. I went an entire week running 2D Win 7 without a driver crash, and have gone back to Aero without a hitch for the past few days.

Mouse cursor bug is still there, but I've gotten so use to it that it doesn't bother me anymore.
 

ASK THE COMMUNITY