• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Question Asus B450-F ROG STRIX Gaming ATX mobo, BIOS 1.0.0.3ABBA, USB 3.x ports flaky, NIC dead

VirtualLarry

Lifer
Aug 25, 2001
49,232
5,468
126
TL;DR: Pulled out RX 580 / RX 470 combo, popped in RX 5700, got BSOD "INACCESSABLE_BOOT_DEVICE_ERROR".



This board, the Asus B450-F ROG STRIX Gaming ATX, is one of the few AM4 boards (pre-X570, at least), that can run TWO NVMe PCI-E 3.0 x4 slots at full-speed, in RAID-0.

I had my rig set up with two Intel 660p 1TB NVMe PCI-E 3.0 x4 SSDs in RAID-0.

It was all humming along, with a Ryzen R5 3600, 4x8GB DDR4-3600 GSKill Trident RGB RAM, and a Sapphire Nitro+ RX 580 4GB, and a Sapphire RX 470 4GB.

Win10 1903. Antec 750W 80Plus Gold PSU. (But was in storage for 3 years NIB.)

I had recently had some issues, before putting in the RX 5700 8GB XFX Reference blower card today. I did have a few spontaneous shutdowns, while mining, with the other cards.

I had also installed Logitech Camera software, to control my webcam.

So, due to the shutdowns, I could have had a corrupted registry, I don't know how common that is anymore.

When I put the RX 5700 card in today, after removing the other two cards, and trying to boot, I entered BIOS, Saved and Exited, booted Windows 10, and BANG! BSOD: INACCESSABLE_BOOT_DEVICE.

Thinking, that's weird, back in the day, that applied to disk controllers, like when you set up Windows 7 with IDE mode instead of AHCI mode, and wanted to switch back and forth.

It eventually, after a few failed boots, went into "Automatic Repair".

But that didn't do anything either.

Also, I had a couple of RealTek-chipset USB networking devices, that also had the CD-ROM driver partition as a USB MF device. I unplugged those.

When "Automatic Repair" came up, I tried "Startup Repair", and it was unable to do anything for me.

I used System Restore to roll back to 9/30, my most up-to-date restore point.

I also, went into BIOS, loaded Optimized Defaults, and re-set things up.

Note that this BIOS, when setting it up for NVMe RAID, you have to go into SATA setttings, enable "NVMe RAID mode", and also go into Boot Options, disable Fast Startup, and disable CSM mode entirely. When you do that, it blurts up a paragraph, about NVMe devices or storage devices or something, needing to have a Secure Boot signature. That, I think, was the key.

I had changed the hardware (And I don't recall ever enabling Secure Boot, I generally don't use it), and I guess I needed to go through that setup in BIOS to again write the BIOS/hardware-hash signature to my boot device? If that's what it was doing?

So, I finally got Windows 10 to load after that, and I'm backing up the system now.

I plugged in both USB networking devices.

Going to updated my video drivers to 19.10.1 (just came out), and then reboot, and re-set my RAM to DOCP mode, 3600 speed, and 1800FCLK.

Then I'm going to see if I can still boot into Windows 10 on my NVMe RAID, or if it gets hosed again.
 
Last edited:

Hans Gruber

Senior member
Dec 23, 2006
966
276
136
Two things. I always pull the Lithium battery after a flurry of changes to my computer. If you have a bios flash button that would probably work just as well. Sometimes for no apparent reason a HDD could disappear for no apparent reason in Windows 10.

Personal opinion, system restore is worthless.

Just like with ram. If your SSD's are not running right. Start with only one bootable drive and get it stable and then add drives after the computer is stable.
 

VirtualLarry

Lifer
Aug 25, 2001
49,232
5,468
126
Yeah, I probably should have done a CLR_CMOS. The system restore, was just in case the registry got corrupted somehow. I don't normally even have it enabled. Somehow it was on this rig.

As far as SSDs go, since I was operating two NVMe in RAID-0, they both had to be online and in the RAID array to function properly.

Anyways, I got it worked out (somehow, between my fiddling). It just seemed really weird to me, that swapping video cards, would cause an "INACCESSABLE_BOOT_DEVICE" BSOD failure, as I had previously thought that those were mostly exclusively limited to disk controller driver errors. But now I believe that it had something to do with Secure Boot, in my case. (I wasn't explicitly using Secure Boot, but somehow, it seemed like it was affecting things, because I had disabled CSM. I might have had better luck setting CSM to "Auto" rather than "Enabled", but I recall from prior BIOS versions, that I had to Disable CSM to get it to boot the NVMe RAID-0 properly.)
 

VirtualLarry

Lifer
Aug 25, 2001
49,232
5,468
126
Well, I thought that this had something to do with the mobo / chipset NVMe RAID, but really, it apparently had to do with my Comfast USB 2.0 AC wifi + BT dongle, when it was installed, if I swapped hardware around, it would make the POST slower, and then when Windows went to boot, it would do "INACCESSABLE_BOOT_DEVICE_FAILURE" or somesuch. Removing it, and then booting Windows, and then re-installing it, seemed to work.

I'm having further problems.

I've got two USB hubs, one AC powered, one not. Both are connected with (different model/vintange) USB 3.0 extension cables.

I've got an Asus B450-F ROG STRIX Gaming ATX mobo, with a Ryzen R5 3600 CPU in it, and an Antec EDG 750W 80Plus Gold PSU (that was in storage for a few years before being used).

I'm having trouble with the USB 3.0 ports on the mobo, and I've already lost both an Asus 10GbE-T PCI-E x4 NIC, as well as the onboard Intel NIC. (Neither shows up at all in Device Manager, not even with problem codes.)

I'm wondering if the USB 3.x troubles, are the mobo, my PSU, or my CPU (SoC USB ports).

The bottom two USB3.0 ports, next to the onboard NIC jack, are flaky. When I reboot my PC, they don't properly detect and power the USB3 hubs, and I lose my mouse and keyboard, unless I unplug and replug both cables after the PC is booted into Windows.
'
The USB 3.1 Gen2 ports (Red) seem to be slightly better, but I didn't want to "Waste" those ports on these things. Then there's a single USB 3.0 port and a Type-C port.

When I plug my Asustor 2.5GbE (RealTek) USB NIC (natively Type-C) into that port in Windows 10, all I get are constant disconnect/reconnects.

When I plugged my two USB3.x extension cables into the top two USB ports, next to the PS/2 port, they were always detected, BUT, I lost USB3.x connectivity. It only dawned on me the other day, that was because those are USB 2.0 ports (!).

So, why don't my USB 3.0 ports behave better? Is this an issue with the CPU SoC, as some of the USB ports come off of there?

I did have my 3600 CPU running at a fixed-clock OC for a few hours (even under 240mm AIO WC), and it hit 117C. Which, I found out later, actually could have been an accurate temp. So maybe I cooked my CPU? I do have hard-crashes/freezes maybe 1-2 times a month, but it runs DC jobs on the CPU just fine, with 4x8GB DDR4-3600 RGB RAM, with an FCLK of 1800, without issues, mostly.

Or is this all down to a flaky PSU, that was in storage for a while, but had a reputation for DOAs? Maybe it has an unstable +5V line, and that "ate" my onboard NIC, damaged my Asustor 2.5GbE USB3.0 Type-C NIC (keeps cutting out on me now), and is just going to continue to cause me problems? Due to being in storage for so long, I don't think that I have any mfg warranty on it.

It should be noted that I have a "Pure Sine" (consumer) UPS from APC, a 1350VA model, on my main rigs, and haven't seen any obvious issues with them.

---

Edit: I switched the UEFI from "Provide power to USB ports during Soft-Off (S5)" to DISABLED. Maybe that selects between +5VSB and +5V for the USB ports, and maybe my +5VSB line on my Antec PSU is too low to power all of my USB3.x devices.
 
Last edited:

ASK THE COMMUNITY