• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

ASRock Z170 Extreme 7+/Samsung 950 PRO Freezing

ArcaneFeenix

Junior Member
Oct 27, 2016
1
0
1
First, my setup:
Mobo: ASRock Z170 Extreme 7+ (BIOS Version 7.10)
Processor: Intel Core i5 6600K 3.5 GHz
HDDs: 1x Samsung 950 Pro M.2 256GB; 1x Intel 320 Series 80GB; 2x 1TB WD Black
Memory: 4x 4GB G.Skill DDR4 3000

I recently purchased the 950 Pro to replace the Intel SSD as my boot drive. Install onto the board went smoothly, booted up into EFI setup and everything looked good (CSM enabled, AHCI mode). Installed Windows 10 (RS1) without any issue. Started to install drivers in audit mode and started getting random freezing (hard freeze, screen frozen, cursor doesn't move). I have tried turning CSM off, changing the SATA mode to RAID, reinstalling RS1 and even installing latest insider build (secure erasing the ssd between each install). The problem is very re-producible (at the moment, trying to install NIC drivers and it freezes before I can click Next for the first time). The interesting thing is the system seems stable if I do any other tasks on it but if I install drivers, it seems to freeze almost every time. Any help at all would be greatly appreciated.

Brandon
 

VirtualLarry

No Lifer
Aug 25, 2001
50,812
6,273
126
What was the last driver that you installed, before the freezing started? I'd start looking there.
 

ASK THE COMMUNITY