• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Question AP kills Internet on Main Router

ctbrown

Member
Jan 7, 2006
92
1
71
I have a TP-link Archer A7 as my main router connected to my Verizon Fios ONT and I have 3 wifi access points which are actually repurposed Asus routers set to AP mode (DHCP turned off). The issue is when I reboot one particular AP (RT-AC66U_B1) remotely via a browser it kills my entire internet for a little while. This does not make sense since I don't loose internet if I simply reboot by power-cycling the router in question or simply unplug the WAN cable (I only loose wifi on that particular AP). This also does not occur with either of my other two APs (RT-N12D1 or RT-AC66W). Of note, I have an unmanaged switch between the main router and all the APs (see screenshot of wired network diagram below)



Network Diagram.jpg
 
Last edited:

JackMDS

Elite Member
Super Moderator
Oct 25, 1999
29,059
250
126
The issue is when I reboot one particular AP (RT-AC66U_B1) remotely via a browser it kills my entire internet for a little while.
May be you can describe functionally what exactly you do?

Where the Remote place is, and through where it travels?


:cool:
 

ctbrown

Member
Jan 7, 2006
92
1
71
By remote, I mean reboot the AP via a browser on a PC on local network, by clicking the reboot button (see screenshot). What happens after that is I get a spinning wheel and a message saying applying settings (don't know why the spinning wheel since I havent changed any settings). It's during this interval that the internet is down on the etire network, not just on the AP in question.

1599250294693.png
 

VirtualLarry

Lifer
Aug 25, 2001
48,808
5,312
126
You mentioned that your APs are in "Mesh" in your diagram. I believe that when in AiMesh mode, all of the router's soft-config controls, affect the entire mesh network. So by clicking "Reboot" on the Mesh-enabled Node, you are rebooting the ENTIRE Mesh, and not JUST that AP. At least, I know that the "upgrade firmware" button works like that too.
 
  • Like
Reactions: Steltek

ctbrown

Member
Jan 7, 2006
92
1
71
You mentioned that your APs are in "Mesh" in your diagram. I believe that when in AiMesh mode, all of the router's soft-config controls, affect the entire mesh network. So by clicking "Reboot" on the Mesh-enabled Node, you are rebooting the ENTIRE Mesh, and not JUST that AP. At least, I know that the "upgrade firmware" button works like that too.
They are not in Mesh (sorry, I don't know where you see that my diagram). Each AP is set-up with unique SSIDs and static IP addresses. One more thing to add is the entire internet goes down, wire, and wifi alike.
 

mxnerd

Diamond Member
Jul 6, 2007
5,491
654
126
You have to use LAN port on those ASUS APs to uplink to your TP-Link router, not the WAN port. Make sure the WAN port for those ASUS APs are disconnected.
 
  • Like
Reactions: Steltek

ctbrown

Member
Jan 7, 2006
92
1
71
You have to use LAN port on those ASUS APs to uplink to your TP-Link router, not the WAN port. Make sure the WAN port for those ASUS APs are disconnected.
I just tried this and the AP works fine using a LAN port, but the issue when rebooting still happens.

To add a little granularity, after I reboot the AP, I get a spinning wheel with a message saying applying updates and a percentage complete. The internet stops working when the percentage hits ~35% and comes back about 5min or so later.
 

JackMDS

Elite Member
Super Moderator
Oct 25, 1999
29,059
250
126
During the years I came few time with regular Wireless Routers that theologies AP mode is quirky.

In most cases the solution was not to use the inner AP Mode but to set the Router manually

Config the unit. with a High Static IP (like 192.156.x.200), disable the DHCP, and keep the WAN port open (i.e. do not plug any thing to it).

BTW, a good practice in complicated LANs is to ilmit the Main Router DHCP to somthing like 1-180 (or less for small LANs). Then give to all none computer Network Devices Static IPs above the DHCP band.


:cool:
 

ctbrown

Member
Jan 7, 2006
92
1
71
I tried resetting the B1 device and setting the Main Router DHCP to 100-199 and set all my IP cameras and other non-computer devices to static IPs. It still did not help. I'll go ahead and try changing the IP to something high, outside the DHCP range.
 

ch33zw1z

Lifer
Nov 4, 2004
30,088
9,096
136
I tried resetting the B1 device and setting the Main Router DHCP to 100-199 and set all my IP cameras and other non-computer devices to static IPs. It still did not help. I'll go ahead and try changing the IP to something high, outside the DHCP range.
Ok, two things:

1. Static IP's should always be set outside the DHCP range. this is likely the root cause of a duplicate IP in the network, which can cause all sorts of problems

2. Setup the router is AP mode, but don't use the built in "ap mode" settings. manual AP mode is relatively easy. Never plug the cable into the WAN port after that, it should be disabled if possible. Use the LAN ports.
 

ctbrown

Member
Jan 7, 2006
92
1
71
Ok, two things:

1. Static IP's should always be set outside the DHCP range. this is likely the root cause of a duplicate IP in the network, which can cause all sorts of problems

2. Setup the router is AP mode, but don't use the built in "ap mode" settings. manual AP mode is relatively easy. Never plug the cable into the WAN port after that, it should be disabled if possible. Use the LAN ports.
I set all static IPs are all outside the DHCP range. How to manually set to AP mode?
 

ch33zw1z

Lifer
Nov 4, 2004
30,088
9,096
136
I set all static IPs are all outside the DHCP range. How to manually set to AP mode?
1. Disable wan port
2. Disable DHCP server
3. Disable dns server
4. Turn off firewalls
5. Set static IP/Subnet mask

note: the AP doesn't need a default gateway, as it's a layer 2 device at this point, and just passing traffic upstream to the router.

You can also use the 3 leftover LAN ports for wired connections.

All clients should get DHCP and dns from the main router
 

ctbrown

Member
Jan 7, 2006
92
1
71
I manually set up as AP and it functioned well, but still had the losing internet reboot glitch. However, I'm happy to report that a firmware update seemed to have solved the problem.
 

ASK THE COMMUNITY