AMD WattMan volt settings revert to default when the workload changes

Bouowmx

Senior member
Nov 13, 2016
853
20
116
#1
PowerColor Radeon RX 480 4 GB, driver 17.7.2
Windows 10
Primary display connected to integrated Intel HD Graphics 3000, and extended desktop connected to AMD GPU (for Radeon Settings to even start at all).

I set all power state volts to 1025 mV, and frequency +2% (~1290 MHz). I run a task that triggers maximum power and takes ~15 minutes (Moo! wrapper). Some seconds are needed to transition to next task. GPU goes to idle frequencies in the mean time. When the next task starts, volts revert to default, ~1162 mV. WattMan does not show that volts reverted to default, but GPU-Z monitoring does. Other settings I've changed are maintained: frequency, fan, and temperature targets. I want my volt settings to be maintained between tasks.

Some guidance needed; I just took some baby steps into tuning AMD Polaris.
 
Last edited:

Bouowmx

Senior member
Nov 13, 2016
853
20
116
#2
I discovered you can set a power state to be the minimum or maximum. So, I set state 7, and memory state 1 to be the minimum. Issue still persists.

I tried changing memory frequencies. Now the weird thing is that the memory setting only applies every other time I click "Apply" :confused:. From default state, I change memory frequency, and click apply, actual memory frequency is 300 MHz. When I change memory frequency again, to say 1800 MHz, and click apply, actual memory frequency is really applied this time, 1800 MHz. The weird thing is that volt settings ARE kept between tasks I am running, ONLY when memory frequency is 300 MHz.

Wow.

Luckily, Moo! wrapper task performance is not dependent on memory in any significant way. I can take the ~10 W power savings from memory and put it back into the GPU. The graphics card has only one 6-pin connector, so I cannot wildly increase power limit.

Still, looking for guidance.
 
Last edited:

railven

Diamond Member
Mar 25, 2010
6,477
152
126
#3
I recall stumbling across posts about this over at r/AMD. Might get better support there. From what I recall, custom bios was the solution or reverting back to an older version of Crimson.
 

Bouowmx

Senior member
Nov 13, 2016
853
20
116
#4
Radeon Settings no longer require a display connected to GPU. Don't know why it gave me a message saying that was needed to start earlier. I updated drivers to 17.9.2. MSI Afterburner and Sapphire TRIXX displays 0 for frequency and volt values.

I think I reached an equilibrium: core frequency 1340 MHz, 1055 mV, memory frequency 300 MHz, GPU-Z GPU-only power ~110 W, volt settings kept consistently. Not going to mess with WattMan further for a bit.
 
Aug 12, 2015
35
0
41
#5
I had similar problem with Sapphire RX 470. After problem started reverting back to older drivers did not help anymore - problem persisted. Tried everything (clean driver install, reinstalling windows). Thought card itself is malfunctioning but found a solution. For me it works if after driver install i do not activate Wattman. Wattool can't hold set voltages but Sapphire own TRIXX tool can so i'm only using this for undervolting as of now. Works as it should.
 

Bouowmx

Senior member
Nov 13, 2016
853
20
116
#6
Update: played around to explore stable frequency-volt pairs
New configuration: Windows 10 1709 (Fall Creators Update), driver 17.10.1

Any memory underclock results in 300 MHz. No more alternating memory frequencies, as described above. In the 300-MHz memory mode, any volt setting above 1000 mV will reset when switching tasks. So, I settle with 1295 MHz, 1000 mV.

In 1750-MHz standard memory mode, core volts cannot be run lower than 1000 mV. I can run ~1075 MHz, 800 mV (minimum volt setting) in 300-MHz memory mode, but in standard memory mode, 1075 MHz core will run at 1000 mV, even though I set 800 mV.

Amazing how inconsistent WattMan is..
 

Similar threads



ASK THE COMMUNITY

TRENDING THREADS