AMD 14.1 Beta causing artifacts?

Discussion in 'Video Cards and Graphics' started by nwo, Feb 5, 2014.

  1. nwo

    nwo Platinum Member

    Joined:
    Jun 21, 2005
    Messages:
    2,307
    Likes Received:
    0
    I just installed the newest 14.1 drivers. My MSI 7870 has severe artifacts while under load (mining). Updating BF4 now to see if the same issue occurs in gaming.

    I was also getting artifacts on the MSI card when I installed the drivers from the CD that came with the card. But once I updated to 13.11 the artifacts went away.

    Should I be concerned and RMA the card or should I just roll back to the last good driver configuration and call it a day?

    Edit update: MSI 7870 is not artifacting in BF4, and that's with the card OCed to 1100/1300. While mining, it is running at 975/1250 and causing artifacts.
     
    #1 nwo, Feb 5, 2014
    Last edited: Feb 5, 2014
  2. Despoiler

    Despoiler Golden Member

    Joined:
    Nov 10, 2007
    Messages:
    1,076
    Likes Received:
    7
    I'm pretty sure I saw on other forums that 14.1 is no good for mining.
     
  3. nwo

    nwo Platinum Member

    Joined:
    Jun 21, 2005
    Messages:
    2,307
    Likes Received:
    0
    In this case 14.1 is good for gaming but no good for mining. I have tried 13.12, 13.9 and am now installing 13.4 and I am still getting artifacts while mining. I also checked my other 7870 and I am having the same issues on that card as well!
     
  4. nwo

    nwo Platinum Member

    Joined:
    Jun 21, 2005
    Messages:
    2,307
    Likes Received:
    0
    Uninstalled, restarted PC, and installed 13.12

    Problem solved.... for now :$
     
    #4 nwo, Feb 5, 2014
    Last edited: Feb 5, 2014
  5. Ryandb2

    Ryandb2 Junior Member

    Joined:
    Nov 19, 2004
    Messages:
    8
    Likes Received:
    0
    I had the same problem with 14.1 and mining on both a 290x and 7950. I ended up resetting them to defaults and not overclocking. Oddly, temps went down and hashes went up. My 7950 was sitting at 550k @ 70C, but now is right around 600k @ 62C. I'm still probably going to go your route and downgrade drivers though.
     
  6. Headfoot

    Headfoot Diamond Member

    Joined:
    Feb 28, 2008
    Messages:
    3,280
    Likes Received:
    79
    I've also seen my hashes maintain speed or even go down in speed when I overclock. Sometimes it goes up with the right ratio of memory OC to core OC
     
Loading...