Question Alphacool XT45 420mm rad (v.2) leaking

thilanliyan

Lifer
Jun 21, 2005
11,923
2,138
126
My Alphacool XT45 420mm is leaking from the opposite end to where the ports are. Unfortunately it looks like it's leaking from were the tube meets the end tank. Radiator was bought and put into service around Sep 2020. I only used distilled water and silver kill coil in the loop.

Anyone ever had this happen?

Any other brands I should be looking for? I've used Swiftech, XSPC, and Black Ice rads...never once had a leak prior to this one.
 
Last edited:

Hail The Brain Slug

Diamond Member
Oct 10, 2005
3,345
1,986
136
Sounds like it was just a manufacturing defect with a solder seam. Can't say I've ever had it happen, but I've only had radiators in service since 2017 so not a long history.

I stick with HWLabs where I can. Black Ice Nemesis GTX is my go-to since opti-flow helps with low flow/fan speed cooling performance. Just make sure you plan the loop with the appropriate flow direction otherwise it doesn't provide any benefit.
 

StefanR5R

Elite Member
Dec 10, 2016
5,725
8,336
136
According to a web search, the chamber opposite to the in/out ports has got a drain/fill port. Are you sure it's not simply the plug of this extra port leaking?
 

thilanliyan

Lifer
Jun 21, 2005
11,923
2,138
126
According to a web search, the chamber opposite to the in/out ports has got a drain/fill port. Are you sure it's not simply the plug of this extra port leaking?
Yes, I checked that, definitely no leak from the other port. Unfortunately it does appear to be from where a tube connects to the end tank. I'll have to break apart the rad to be sure but I could not see anything coming out of the drain port.

I decided to stick with a brass radiator (never had any issues with those) compared to the Alphacool "all copper" radiator and the only one I could find relatively easily here in Canada is the EK Quantum surface X420. Hardware Labs rads are hard to find here in Canada.