All shortcuts now have .lnk extension?

Discussion in 'Operating Systems' started by Bluefront, Jan 17, 2008.

  1. Bluefront

    Bluefront Golden Member

    Joined:
    Apr 20, 2002
    Messages:
    1,466
    Likes Received:
    0
    For some unknown reason, all the desktop shortcuts this morning now have a .lnk extension. In fact even the shortcuts in the program list are like this. They all still work ok. Is there a general setting in XP SP2 to remove this, without having to rename everything? Anybody know what could have happened?
     
  2. Loading...


  3. bsobel

    bsobel Moderator Emeritus<br>Elite Member

    Joined:
    Dec 9, 2001
    Messages:
    13,350
    Likes Received:
    0
    Run regedit, under:

    HKEY_CLASSES_ROOT\lnkfile

    You should have an entry called NeverShowExt (REG_SZ) and the dat is blank. If not, in the right column, create a REG_SZ entry named "NeverShowExt" and leave the data blank.
     
  4. Bluefront

    Bluefront Golden Member

    Joined:
    Apr 20, 2002
    Messages:
    1,466
    Likes Received:
    0
    That fixed it ....thanks. Actually the entry read "AlwaysShowExt"........ How the heck did that happen? I sure didn't do it. It happened on the first boot this morning.
     
  5. postmortemIA

    postmortemIA Diamond Member

    Joined:
    Jul 11, 2006
    Messages:
    7,612
    Likes Received:
    19
    your haxor has sense of humor?
     
  6. VirtualLarry

    VirtualLarry Lifer

    Joined:
    Aug 25, 2001
    Messages:
    36,500
    Likes Received:
    931
    Run any registry cleaners lately?
     
  7. Bluefront

    Bluefront Golden Member

    Joined:
    Apr 20, 2002
    Messages:
    1,466
    Likes Received:
    0
    No registry cleaners.....would that have caused the problem, or prevented the problem?
     
  8. theprodigalrebel

    Joined:
    Oct 4, 2004
    Messages:
    10,521
    Likes Received:
    1
    A registry cleaner cleaner would most likely cause the default setting to load - and that is to Hide Extensions.