All my folders in XP are set to read-only and I can't change it..

Ph33zy

Senior member
Mar 5, 2000
944
0
76
Every single folder on my Win XP SP2 is set to readonly (not the files, just the folder itself) and I can't change it. Kaspersky isn't picking up anything and I was wondering if this is normal? I never noticed it before. Please someone educate me! Thanks
 

pcgeek11

Lifer
Jun 12, 2005
21,305
4,425
136
Ph33zy,

On the C:\ For all of the folders under the properties for that folder show a light grey check in the read only check block. Is that correct?

If that is what you are referring to please note that in Windows XP all folders have the Read-only attribute (checked and greyed out) by default. Try this: Create a new empty folder and see it will have this same attribute applied to it. Every XP system that I have looked at so far is like this.

This is the normal default behaviour for Windows XP. Is it causing you some particular problem? If not I wouldn't worry about it. If it is causing you some problems check out What MS has to say here: Knowledge Base Article # KB326549

Quote
Unlike the Read-only attribute for a file, the Read-only attribute for a folder is typically ignored by Windows, Windows components and accessories, and other programs. For example, you can delete, rename, and change a folder with the Read-only attribute by using Windows Explorer. The Read-only and System attributes is only used by Windows Explorer to determine whether the folder is a special folder, such as a system folder that has its view customized by Windows (for example, My Documents, Favorites, Fonts, Downloaded Program Files), or a folder that you customized by using the Customize tab of the folder's Properties dialog box. As a result, Windows Explorer does not allow you to view or change the Read-only or System attributes of folders.
End of quote

I'm fairly certain that this has something to do with " Simple File Sharing " and you can get around this "Read Only " if you do the following:

Note of caution make sure you know what you are doing before mucking around too much with system files and folders if you are the administrator it will allow you to shoot yourself in the head!!!! I cannot stress this enough!

If it ain't broke don't fix it!

In Windows Explorer click on Tools > Folder Option > View > at the bottom of the list Uncheck " Use Simple file sharing , Recommended " Then click on apply.

Then go to to MY Computer > right click on C: > click on the Sharing Tab and the Security Tab > Then you can reassign folder by folder who can access what... Just make sure you read the caution note above.

Don't blame me for mucking up the system if it goes down for permissions problems. Make sure you know what you are doing before you commit.

pcgeek11
 

Ph33zy

Senior member
Mar 5, 2000
944
0
76
I just installed trillian and notice that it wasn't saving my buddy aliases on my contact list, so i googled the issue could be caused if my buddylist file is set to readonly or the directory that the file was in was also set to readonly.

Thats when i first noticed that i couldnt change any folder to readonly.

I think that it just might be a trillian bug and not a windows bug now. Thanks for clarifying this for me!