Question 9700k stuttering in games: hardware issue?

Minisi

Junior Member
Jun 15, 2019
14
0
11
I have what I’d think is a fairly beefy PC with an i7 9700k, a 2080, 16 GB 3200mhz RAM, 2 SATA SSDs, connected to a 1440p 144hz monitor. However, while playing Assassin's Creed: Origins, I frequently experience micro-freezes lasting anywhere from 2-3 seconds in Alexandria and other cities like Memphis, where my processor is pretty much constantly pegged at 100% usage. This only happens with an unlocked framerate, if I limit it to 60 in-game it has no issues. What I want to know is what is causing this. Is it my processor reaching 100% usage? Or is there something else wrong with my system? I have a laptop with an i7 8750h, a 2070, 32GB 2666mhz RAM an nvme SSD, and a 1080p 144hz monitor and I don’t experience these issues in big cities, which is strange considering it is a significantly less powerful system. I have also played Odyssey and the same thing happens in large areas when the processor hits 100% usage. However, my laptop's processor also hits 100% usage in Odyssey but doesn't stutter/freeze like my desktop, so I'm starting to worry something is wrong with my PC, or maybe I messed up when building it. Does anyone know what could be causing this? Is it the lack of hyperthreading in the 9700k or something more serious? Any advice is greatly appreciated.

Under load all my cores while playing Origins are all at around the same percentage, so 50% in the world itself and anywhere from 95% to 100% in Alexandria/other large cities. At 4.9ghz turbo boost temps never exceed 62 C.

GPU temps never exceed 75 C

I have a Corsair HX850i

No overclocking

Z390 Aorus Ultra, BIOS it had out of the box

I've checked task manager, not resource manager, but everything that was running was 1% or less cpu usage save for the game itself.

Also my laptop is an Asus ROG Strix Scar II - GL504GW, if that helps.

I only built my PC like 4 weeks ago, but the only game this heavy stuttering has happened with is ACO. However, when I was playing other games, there would be instances where right after loading into the world, there would be a significant stutter, and then gameplay would continue normally for hours on end perfectly smoothly. These were all other AC titles: Unity, Syndicate.

Moreover, I had an instance where the game was loading an area for 5 minutes before I gave up and restarted. There was also an instance where right after loading an area the game crashed, but not the pc. None of this has happened on my laptop and I have no clue what is causing this behavior.
 

deustroop

Golden Member
Dec 12, 2010
1,537
205
116
If you reduce the monitor freq and/or the resolution I suppose the problem goes away ?
 

ozzy702

Senior member
Nov 1, 2011
986
382
136
Test your ram. Update your bios to a newer version (some of those early Gigabyte bios were really buggy, I have a z390 Master and I probably won't go Gigabyte again).

You could DDU and install new GPU drivers. Check to see if all your mobo drivers are up to date.

Those are the things I'd do first before looking at anything else assuming you did a clean install of Win10 with this machine when you built it.

If you do all those things and still have issues you could test your SSDs and see if you potentially are having problems with one of them but if other games are running fine off the same drive it's probably not it.
 
Last edited:
  • Like
Reactions: Thunder 57

Minisi

Junior Member
Jun 15, 2019
14
0
11
If you reduce the monitor freq and/or the resolution I suppose the problem goes away ?
Yeah, if I limit in game frames to 60 there's no issue.


Test your ram. Update your bios to a newer version (some of those early Gigabyte bios were really buggy, I have a z390 Master and I probably won't go Gigabyte again).

You could DDU and install new GPU drivers. Check to see if all your mobo drivers are up to date.

Those are the things I'd do first before looking at anything else assuming you did a clean install of Win10 with this machine when you built it.

If you do all those things and still have issues you could test your SSDs and see if you potentially are having problems with one of them but if other games are running fine off the same drive it's probably not it.
My RAM is fine, I did the Windows memory check and it reported no issues, I'm on the latest GPU drivers as well.

I have this game installed on my OS drive, so I'm gonna reinstall on the other drive and see if that fixes anything.
 

ozzy702

Senior member
Nov 1, 2011
986
382
136
Yeah, if I limit in game frames to 60 there's no issue.




My RAM is fine, I did the Windows memory check and it reported no issues, I'm on the latest GPU drivers as well.

I have this game installed on my OS drive, so I'm gonna reinstall on the other drive and see if that fixes anything.

Do you have something else in the background running that's crushing your IO and/or CPU? Teamviewer? Anti-virus?
 

ehume

Golden Member
Nov 6, 2009
1,428
50
91
What happens with 90 fps rather than 144? Also, I notice that your monitor has a vertical of 1444 px, and the one that works is a 1080.
 

Minisi

Junior Member
Jun 15, 2019
14
0
11
Do you have something else in the background running that's crushing your IO and/or CPU? Teamviewer? Anti-virus?
I've looked at all that and nothing really stood out tbh

What happens with 90 fps rather than 144? Also, I notice that your monitor has a vertical of 1444 px, and the one that works is a 1080.

I don't know, I haven't tested that, all I've done was limit the frames the 60, but given that in Alexandria I get 70 when it's not stuttering, I don't what good that would do.
 

VirtualLarry

Lifer
Aug 25, 2001
44,787
3,825
126
If the game is run un-throttled, and it uses up 100% of CPU time on the game, then yes, OF COURSE, it's going to stutter. The Windows NT scheduler, has a "feature", that threads of lower priority that don't get to run in N seconds, get a chance to run (priority boost) every M seconds, for a short time, and I believe at that point the game threads are not being scheduled, so that's the "stutter" that you see.

Same thing happened with the G3258 dual-core CPU, run games without setting a FPS cap, stutter-city. Set a FPS limit (such as in GTA V, like 30fps), and it was smooth again.

Again, this is all NORMAL. Just because you have a high-powered system, doesn't mean that it WON'T STUTTER. (*Edit: If you don't take the proper precautions / steps in game setup.)
 
  • Like
Reactions: DigDog

Minisi

Junior Member
Jun 15, 2019
14
0
11
If the game is run un-throttled, and it uses up 100% of CPU time on the game, then yes, OF COURSE, it's going to stutter. The Windows NT scheduler, has a "feature", that threads of lower priority that don't get to run in N seconds, get a chance to run (priority boost) every M seconds, for a short time, and I believe at that point the game threads are not being scheduled, so that's the "stutter" that you see.

Same thing happened with the G3258 dual-core CPU, run games without setting a FPS cap, stutter-city. Set a FPS limit (such as in GTA V, like 30fps), and it was smooth again.

Again, this is all NORMAL. Just because you have a high-powered system, doesn't mean that it WON'T STUTTER. (*Edit: If you don't take the proper precautions / steps in game setup.)
But if that's the case why doesn't my laptop stutter when it reaches 100% cpu usage in Origins and Odyssey? It just drops frames, but doesn't stutter.

It has a 6 core/12 thread i7 8750h
 

VirtualLarry

Lifer
Aug 25, 2001
44,787
3,825
126
Because the additional background threads get to run (scheduled) on the HyperThreads, so that the main threads don't get suddenly interrupted.

Think of it as kind of a pressure-release thing. Without HyperThreading, and with all main CPU cores running "realtime" gaming threads, those "background" thread timeslices that they need to run, build up, and eventually, Windows NT's scheduler, "releases the pressure", and lets those low-priority threads execute at a higher priority for a brief moment, every so often.

With HyperThreading, those background threads, can run on the HyperThreads, assuming that the game doesn't shove them full of threads too.

Edit: It's not all CPU, either, the GPU and its drivers have an effect as well. The CPU feeds the GPU, and if the GPU is waiting, the CPU may wait as well. (Frame-limiting will do that too.) That gives background tasks a brief period to operate as well.
 

Minisi

Junior Member
Jun 15, 2019
14
0
11
Because the additional background threads get to run (scheduled) on the HyperThreads, so that the main threads don't get suddenly interrupted.

Think of it as kind of a pressure-release thing. Without HyperThreading, and with all main CPU cores running "realtime" gaming threads, those "background" thread timeslices that they need to run, build up, and eventually, Windows NT's scheduler, "releases the pressure", and lets those low-priority threads execute at a higher priority for a brief moment, every so often.

With HyperThreading, those background threads, can run on the HyperThreads, assuming that the game doesn't shove them full of threads too.

Edit: It's not all CPU, either, the GPU and its drivers have an effect as well. The CPU feeds the GPU, and if the GPU is waiting, the CPU may wait as well. (Frame-limiting will do that too.) That gives background tasks a brief period to operate as well.
I think I get it now, thank you. Seems like I may refund and get a 9900k instead, but at least there seems to be nothing seriously wrong with my pc. Thank you for your help.
 

Keljian

Member
Jun 16, 2004
81
12
71
I had exactly the same issue on my 9700k. I did two things:
1. Disabled Bluetooth
2. Closed slack (cause it was using the GPU)

Doing those two things fixed it
 

Minisi

Junior Member
Jun 15, 2019
14
0
11
I had exactly the same issue on my 9700k. I did two things:
1. Disabled Bluetooth
2. Closed slack (cause it was using the GPU)

Doing those two things fixed it
I'll try the bluetooth thing but I don't use slack so I'll have to find something else to get rid of. Thank you for the help.
 

Arkaign

Lifer
Oct 27, 2006
19,795
325
126
I must say, that is pretty bizarre. I have an 8086k as main gaming rig (with a 120hz UW Gysnc and 1080ti Aorus OC). Disabling HT makes basically zero difference to this game for me (6C/6T vs 6C/12T). Runs smoothly either way, though I think there was some broken setting in the game, I think it was the skybox setting that can cause awful hitching for some reason.

The game uses two kinds of intrusive DRM in combo, which tends to crush certain CPU configs, but your 9700k should be well above that threshold.
 

Minisi

Junior Member
Jun 15, 2019
14
0
11
I must say, that is pretty bizarre. I have an 8086k as main gaming rig (with a 120hz UW Gysnc and 1080ti Aorus OC). Disabling HT makes basically zero difference to this game for me (6C/6T vs 6C/12T). Runs smoothly either way, though I think there was some broken setting in the game, I think it was the skybox setting that can cause awful hitching for some reason.

The game uses two kinds of intrusive DRM in combo, which tends to crush certain CPU configs, but your 9700k should be well above that threshold.
Do you have any ideas what could be causing it? The NT scheduler thing makes sense but still a 9700k shouldn't have any issue. It's really frustrating.
 

Arkaign

Lifer
Oct 27, 2006
19,795
325
126
There's a higher binned version of 9900 coming that is guaranteed stock all core 5Ghz, given Ryzen2 I'd expect it to come in at no more expensive than current model, and possibly even less.

The situation is incredibly bizarre though, and may persist even with the new CPU. I tried restoring my 8086k to stock clocks, disabled HT, and disabled turbo (!), so running at 3.7Ghz 6C/6T, and I don't get stuttering in Odyssey or Origins. Framerates drop from 75-120 to 55-110ish, but otherwise feels great.

Try this : set resolution to native, set every other video settings to minimum. Make sure Gsync is enabled in the driver and at the display. Make sure the framerate lock thing is off. This should expose your actual CPU performance in this game, or close enough with only native resolution above minimum settings. Whether you still have hitching here or not would be helpful in determining what is causing it.
 

scannall

Golden Member
Jan 1, 2012
1,447
815
136
It doesn't sound like a hardware problem to me. Sounds like either a Windows issue, driver issues, or a background process hogging the CPU intermittently. Your hardware is plenty fine to run nice and smooth all the time, so I doubt that spending more on hardware will fix your problem.
 
  • Like
Reactions: CuriousMike

Minisi

Junior Member
Jun 15, 2019
14
0
11
It doesn't sound like a hardware problem to me. Sounds like either a Windows issue, driver issues, or a background process hogging the CPU intermittently. Your hardware is plenty fine to run nice and smooth all the time, so I doubt that spending more on hardware will fix your problem.
Any idea what it could be?
 

scannall

Golden Member
Jan 1, 2012
1,447
815
136
Any idea what it could be?
Run msconfig. Go to the services tab, and exclude Microsoft services. Then Google each service that is left. Shouldn't be a lot of them. For your video drivers, use DDU to uninstall all scraps. Then let Windows find and install video drivers. If you've switched brands of video cards without a full uninstall/reinstall it will often times cause problems.
 

ASK THE COMMUNITY