• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

7950 and Monster Truck Nitro, don't laugh

CU

Platinum Member
Aug 14, 2000
2,314
21
81
I just upgraded to a 7950. For some reason Monster Truck Nitro no longer plays at 1080p fullscreen. It will only play up to 1600x900 windowed. Any higher and it freezes with garbled graphics as soon as it loads the menu. So far that is the only game that has a problem. I played BL2 for about 30 minutes last night and it ran fine. My kids really like the game so it would be nice to get it working again at 1080p.
 

CU

Platinum Member
Aug 14, 2000
2,314
21
81
That was not me, but that is the same problem. Unfortunately that is not the best solution for me as my kids will never remember to load the game in a lower resolution and change it in game every time. It does work though as I just tried it.
 

CU

Platinum Member
Aug 14, 2000
2,314
21
81
Judging by this log I would say they never thought of a GPU having over 2Gigs of ram so with 3Gigs it reports it as -1Gig.

Audio devices: Generic Hardware (default: Generic Hardware)
Player: init engine
Direct3D:
Version: Direct3D 9.0c [aticfx32.dll 8.17.10.1230]
Renderer: AMD Radeon HD 7900 Series
Vendor: ATI
VRAM: -1024 MB
D3D: VRAM amount suspiciously low (less than 32MB for PS2.0 card)
desktop: 1920x1080 60Hz; virtual: 1920x1080 at 0,0
Checking for udpates
UnityEngine.Debug:Log(Object)
VersionUpdater:checkUpdateAsync()
VersionUpdater:Awake()

(Filename: \unitybuild\unity\Runtime\Export\Generated\BaseClass.cpp Line: 1651)

Stacktrace:

at (wrapper managed-to-native) UnityEngine.Graphics.Internal_DrawMeshNow1 (UnityEngine.Mesh,UnityEngine.Vector3,UnityEngine.Quaternion,int) <0x00004>
at (wrapper managed-to-native) UnityEngine.Graphics.Internal_DrawMeshNow1 (UnityEngine.Mesh,UnityEngine.Vector3,UnityEngine.Quaternion,int) <0xffffffff>
at UnityEngine.Graphics.DrawMeshNow (UnityEngine.Mesh,UnityEngine.Vector3,UnityEngine.Quaternion,int) <0x00042>
at UnityEngineInternal.ImposterRenderTexture.UpdateImposter (UnityEngine.Camera,UnityEngine.Light[],UnityEngine.Rect,UnityEngineInternal.TreeDatabase/Prototype) <0x003d7>
at UnityEngineInternal.ImposterRenderTexture.UpdateImposters (UnityEngine.Camera,UnityEngine.Light[]) <0x002a5>
at UnityEngineInternal.TreeRenderer.Render (UnityEngine.Camera,UnityEngine.Light[],single,single,single,int,bool,int) <0x00a60>
at UnityEngine.Terrain.CullAllTerrains () <0x009b8>
at (wrapper runtime-invoke) UnityEngine.StackTraceUtility.runtime_invoke_void (object,intptr,intptr,intptr) <0xffffffff>
Receiving unhandled NULL exception
Trying to recover from null exception
 
Last edited:

ASK THE COMMUNITY