5820k and cpu-z curiosity

elkido122

Senior member
Jan 10, 2015
249
0
41
#1
i was running cpu-z with my new system that has a 5820k. is it normal ( even with power plan on power mode) and xmp turned on for the cpu-z program to be showing that the processor is changing core clock speed from 1.498ghz to 3.6ghz? i thought it would run all the time at 3.6 with xmp on? thanks guys
 

Burpo

Diamond Member
Sep 10, 2013
4,054
27
126
#2
Couple ways you can do that, either turn off speedstep and C states in bios, or set your CPU Performance to 100% in Windows.

Your 5820K is running normal. There's nothing wrong with having speedstep enabled and allowing the CPU to downclock and save power when possible.
 

elkido122

Senior member
Jan 10, 2015
249
0
41
#3
is it ok to keep turbo boost 2.0 off? will all 6 of my cores still run at the max there suppose to run at?
 

elkido122

Senior member
Jan 10, 2015
249
0
41
#5
well, how often does it actually kick in? since it is work load related , wouldnt it be ok it my cores ran at 3.6 like they are with it off?
 
Mar 10, 2004
28,493
224
126
#6
well, how often does it actually kick in? since it is work load related , wouldnt it be ok it my cores ran at 3.6 like they are with it off?
It's supposed to drop down to a low idle clock when it has no work to do. There's no reason to have it running at high clocks all the time.

You can turn those power saving features off if you want, it won't hurt anything but your electric bill.
 

elkido122

Senior member
Jan 10, 2015
249
0
41
#7
How can I assure all 6 of my cores are running at the same frequency ? Thanks
 
Mar 10, 2004
28,493
224
126
#8
How can I assure all 6 of my cores are running at the same frequency ? Thanks
They will normally only run at the same frequency when idle, or when they are all doing work. Often the work load will not cause all the cores to run at the highest clock. The work load will vary on each core, and each core will vary it's clock speed accordingly.

It would be odd for all the cores to run at the same frequency all of the time except at idle, unless you deliberately disable the power saving features such as Speed Step and the idle states.

You can also set Windows to High Performance.

You are not getting the work done any faster by disabling the power saving features. You are just wasting electricity, imo.

You sound like you do not want your CPU to ever be at idle.

If you want to see all of your cores bust ass, run Intel Burn Test. That will make all of your cores work extremely hard.

http://intelburntest.en.lo4d.com/
 

XabanakFanatik

Platinum Member
Oct 10, 2005
2,049
0
106
#9
I set my 5960x overclock with a manual voltage. I tested idle power consumption with speedstep on and clocks lowering at idle vs. speedstep disabled and clocks maintaining at full speed. I did not observe a power consumption difference at idle between these two cases.

I think to really save power, you have to have a voltage setting that adjusts with clockspeed enabled, which you probably do. It can be harder to make that work right when overclocking.

You have to leave turbo boost enabled in the bios to use multipliers over the base clock, even when overclocking.

I would leave speedstep on and let it downclock if I did not have the manual voltage set and I saw a power consumption decrease.
 
Aug 25, 2001
43,581
533
126
#10
When was the last CPU Core generation, in which the frequency of the CPU cores was in lockstep? Ivy Bridge? Haswell? I think that somewhere around Haswell-E or Broadwell-E, they changed that. (Certainly, for turbo Boost 3.0, they would have had to.)
 

WhoBeDaPlaya

Diamond Member
Sep 15, 2000
7,368
2
126
jwtioh.bluesonic.net
#11

ASK THE COMMUNITY

TRENDING THREADS