Go Back   AnandTech Forums > Software > Operating Systems

Forums
· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2014
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions
   

Reply
 
Thread Tools
Old 07-06-2013, 04:56 PM   #1
CA19100
Senior Member
 
Join Date: Jun 2012
Location: Seattle, WA
Posts: 465
Default Windows 8.1 Preview Won't Sleep Automatically

I'm giving Windows 8 another shot, after giving up and reinstalling Windows 7 a few months ago. They've actually fixed a number of the irritations I had with 8.0, to the point that the positives are finally outweighing the negatives for me.

There is one lingering problem, however, that I haven't been able to solve: The thing just won't go to sleep on its own. The screen will go blank according to that setting in Power Options, but it won't fully put the system to sleep.

Things I've tried:
  • Updated to latest BIOS version.
  • Deactivated every wake_armed item with powercfg -devicedisablewake. wake_armed lists nothing now.
  • Unplugged all USB devices, including the keyboard and mouse.
  • Disabled and reenabled Hybrid Sleep to see if it made a difference (it didn't).
Honestly not sure what else to try. With Windows 7, I was able to get it to auto-sleep without an issue. Any ideas on what else I might try?


System is a homebuilt Intel i5-3570 desktop machine, with a Gigabyte H77M-D3H board and an AMD 6870 graphics card.

Thanks!
CA19100 is offline   Reply With Quote
Old 07-06-2013, 09:16 PM   #2
Bubbaleone
Golden Member
 
Bubbaleone's Avatar
 
Join Date: Nov 2011
Posts: 1,651
Default

It's fine to use powercfg /devicequery wake_armed, but those devices can just as easily be taken care of in Device Manager and since they're obvious and simple to disable they aren't usually the problem. More than likely it's an application or driver power request that's preventing sleep mode. Use these commands to isolate the more obscure processes:

powercfg /requests
(Enumerate application and driver Power Requests. Power
Requests prevent the computer from automatically powering off
the display or entering a low-power sleep mode.)

powercfg /waketimers
(Enumerate the active wake timers. If enabled, the expiration of a
wake timer wakes the system from sleep and hibernate states.)

powercfg /lastwake
(Reports information about what woke the system from the last sleep transition.)

.
__________________
ASRock Z77 Extreme9 | i7-3770K@4.6GHz | 32GB Corsair Dominator Platinum | Corsair H100i
2 x RAID 10 Samsung 840 Pro Series MZ-7PD256BW | 4 x RAID 10 WD 2TB RE WD2000FYYZ
2 x MSI R7950 Twin Frozr 3GD5/OC XFire | HP ZR2440w IPS
Lian Li PC-7HX Black Aluminum | XFX ProSeries P1-1000-BELX | HEAT

Last edited by Bubbaleone; 07-06-2013 at 10:29 PM.
Bubbaleone is offline   Reply With Quote
Old 07-07-2013, 04:59 PM   #3
CA19100
Senior Member
 
Join Date: Jun 2012
Location: Seattle, WA
Posts: 465
Default

I appreciate the additional info. Unfortunately, I've still drawn a blank. Powercfg /requests shows "None" for all items, and there are no wake timers set. I also ran Powercfg /energy for five minutes, and nothing came up that would prevent sleep.

On a hunch, I tried something else, and I think I found a big clue: Disabling my PCIe wireless card allows it to sleep with no problems. Reenabling it prevents the sleep. For troubleshooting purposes, I disabled the wireless card and switched to a wired connection on the motherboard's ethernet connector. Same issue -- no sleep. If I unplug the network cable and don't touch a thing, and it goes to sleep on schedule. Drivers are the ones built into Windows. (I tried updating to newer ones from Rosewill's web site, but Windows didn't install them, saying the latest ones were already installed.)


So it seems to be something to do with network connectivity. I'm not quite sure what to do about it, though. I've already disabled the Windows Media sharing service. Anything else I should check? (I'm somewhat new to Windows troubleshooting, but I'm learning quickly!) Both network adapters have the "Allow this device to wake the computer" un-checked.

Thanks again.

Last edited by CA19100; 07-07-2013 at 09:34 PM.
CA19100 is offline   Reply With Quote
Old 07-08-2013, 06:51 PM   #4
SimMike2
Platinum Member
 
Join Date: Aug 2000
Posts: 2,474
Default

From my past experience, beta or preview copies have trouble with things like sleep mode. Not saying this is the case here, but the change from beta to release version is sometimes very dramatic in the little things that all of a sudden start working.
SimMike2 is offline   Reply With Quote
Old 07-08-2013, 06:53 PM   #5
CA19100
Senior Member
 
Join Date: Jun 2012
Location: Seattle, WA
Posts: 465
Default

Good thought; it is just the preview version. I've tried everything else I can think of, so I'm just going to live with it until the real 8.1 is released and see if that fixes it. At least when it's going to sleep (manually), it's staying asleep, so it could be a lot worse.

Thanks guys!
CA19100 is offline   Reply With Quote
Old 07-19-2013, 03:08 PM   #6
rscully
Junior Member
 
Join Date: Jul 2013
Posts: 1
Default

Seen on other forums that disabling IPV6 resolves the issue. Could be used as a temporary fix
rscully is offline   Reply With Quote
Old 07-19-2013, 04:53 PM   #7
CA19100
Senior Member
 
Join Date: Jun 2012
Location: Seattle, WA
Posts: 465
Default

Quote:
Originally Posted by rscully View Post
Seen on other forums that disabling IPV6 resolves the issue. Could be used as a temporary fix
That did it! Thanks so much for the reply; I never in a million years would have thought to try that. Guess I was on the right track with the networking issue, but had no idea how to solve it. Much appreciated.

For others who want to try it, the procedure for disabling IPv6 is a little different in Windows 8 vs. 7. This is how I disabled it in the 8.1 Preview:

http://www.techunboxed.com/2012/08/h...windows-8.html


Hopefully this will be solved before we actually need IPv6, but it's a good workaround for now.
CA19100 is offline   Reply With Quote
Old 10-12-2013, 02:22 PM   #8
johnpombrio
Member
 
Join Date: May 2005
Posts: 63
Default Disable network port.

I found that disabling the network port will allow automatic sleep to work. This will not work if I leave the network port disabled during a restart or shutdown, probably because Windows is trying to phone home or something else is. Now to figure out WHY, heh.
johnpombrio is offline   Reply With Quote
Old 10-12-2013, 07:05 PM   #9
johnpombrio
Member
 
Join Date: May 2005
Posts: 63
Default

K, I solved it! It is an issue with HOMEGROUP in Win8.1 Pro. Mind you, the HOMEGROUP computers that are preventing sleep don't even have to be turned on! Basically, I had to take the three computers in the house, unshare ALL files/folders (shift-left click to select all files and folders, right click-sharing-stop sharing), and have them leave the old HOMEGROUP. I then created a new HOMEGROUP with a new password and made sure that I could share files and folders back and forth.

To verify that this is your problem, just disable the network adapter and set the sleep to one minute. Wait 5 minutes and see if it sleeps. EDIT: You may need to unshare all files/folders on the computer before this will work.

Now the two Win8.1 Pro computers sleep! (takes a couple of minutes to fall asleep so some patience is needed).

I now have two others that have had this problem and my fix worked for both of them. I wish I could submit a MS bug report...

EDIT: nope, no fix. I even disabled Homegroup entirely and just used guest accounts to share files. Worked for a while then the dreaded "come downstairs to find computer awake" mode.

A possible workaround is to disable the POWER setting in the msconfig services section. You are stuck with what you set your sleep time to and the "no pasword on wake from sleep" gets disabled. I am still testing this...

Last edited by johnpombrio; 11-08-2013 at 04:48 PM.
johnpombrio is offline   Reply With Quote
Old 11-02-2013, 04:37 PM   #10
johnix2013
Junior Member
 
Join Date: Nov 2013
Posts: 1
Default Homegroup Removal

I have a 2007 vintage HP model PC, that was working fine on 8.0 before I upgraded to 8.1. The fix for me was removing it from the Homegroup. Insomnia cured. I am not sharing files with my other PCs anyway. I too originally noticed that sleeping worked fine when I unplugged the network cable.

Edit: I spoke too soon. While it worked multiple times yesterday after I removed it from the Homegroup, today the only way I can make it sleep on its own is to unplug the network cable.

Last edited by johnix2013; 11-03-2013 at 01:43 PM.
johnix2013 is offline   Reply With Quote
Old 11-02-2013, 09:54 PM   #11
Raincity
Diamond Member
 
Raincity's Avatar
 
Join Date: Feb 2000
Location: Las Vegas, NV, USA
Posts: 4,259
Default

My fix on two machines was to disable let network adapter wake up sleep and all was well again.
Raincity is online now   Reply With Quote
Old 11-03-2013, 06:30 AM   #12
bbhaag
Golden Member
 
bbhaag's Avatar
 
Join Date: Jul 2011
Location: Illinois
Posts: 1,379
Default

Quote:
Originally Posted by Raincity View Post
My fix on two machines was to disable let network adapter wake up sleep and all was well again.
I had to do this when 7 was on my machine as well as with 8. I could never get my computer to fully go to sleep until I clicked that option in the adapter properties.
__________________
The more it hurts the better it feels
bbhaag is offline   Reply With Quote
Old 11-04-2013, 01:16 PM   #13
postmark
Senior Member
 
Join Date: May 2011
Posts: 295
Default

Quote:
Originally Posted by bbhaag View Post
I had to do this when 7 was on my machine as well as with 8. I could never get my computer to fully go to sleep until I clicked that option in the adapter properties.
I think if you wanted to dig deeper the setting that was causing the wake was the "wake on directed packet" which occur all the time. If you only leave "wake on magic packet" then you could achieve full sleep with still supporting wake if you really need it.
postmark is offline   Reply With Quote
Old 11-04-2013, 06:36 PM   #14
bbhaag
Golden Member
 
bbhaag's Avatar
 
Join Date: Jul 2011
Location: Illinois
Posts: 1,379
Default

Quote:
Originally Posted by postmark View Post
I think if you wanted to dig deeper the setting that was causing the wake was the "wake on directed packet" which occur all the time. If you only leave "wake on magic packet" then you could achieve full sleep with still supporting wake if you really need it.
Thanks for the tip man. I'll give this a try later tonight.
__________________
The more it hurts the better it feels
bbhaag is offline   Reply With Quote
Old 11-08-2013, 04:50 PM   #15
johnpombrio
Member
 
Join Date: May 2005
Posts: 63
Default

For folks that are still having this issue, we have 16 pages of frustrated postings at the eight forums site:
http://www.eightforums.com/general-s...ses-sleep.html
johnpombrio is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.