Go Back   AnandTech Forums > Software > All Things Apple

Forums
· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2014
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions
   

Reply
 
Thread Tools
Old 03-23-2012, 06:06 PM   #1
dmw16
Diamond Member
 
Join Date: Nov 2000
Posts: 7,595
Default iMac Volume Control Greyed Out

I have a 27" i5 iMac and I've noticed recently that my volume control is greyed out. I can't adjust the volume with the slider or the keyboard and the speaker icon (and the screen notifications are greyed out).

When I plug in headphones they work fine, but when I remove them the icon reverts back to grey.

Any ideas?

EDIT: Plugging in headphones then removing them seems to fix it if I leave the headphones in for a little bit first.
__________________
My Heatware
dmw16 is offline   Reply With Quote
Old 03-23-2012, 07:10 PM   #2
ChAoTiCpInOy
Diamond Member
 
Join Date: Jun 2006
Posts: 6,355
Default

Might be something is making the iMac think that an optical cable is plugged in. Check your audio settings.
ChAoTiCpInOy is online now   Reply With Quote
Old 03-23-2012, 08:13 PM   #3
Adramalech
Member
 
Adramalech's Avatar
 
Join Date: Aug 2010
Location: Honolulu, HI
Posts: 168
Default

Quote:
Originally Posted by dmw16 View Post
I have a 27" i5 iMac and I've noticed recently that my volume control is greyed out. I can't adjust the volume with the slider or the keyboard and the speaker icon (and the screen notifications are greyed out).

When I plug in headphones they work fine, but when I remove them the icon reverts back to grey.

Any ideas?

EDIT: Plugging in headphones then removing them seems to fix it if I leave the headphones in for a little bit first.
If you have time, please create another user account and see if the same thing happens.

If it does, you might have a hardware issue. Just like was previously mentioned, the iMac more than likely thinks something is plugged into headphone jack and you plugging and unplugging a set of headphones fixes it temporarily. Did you have an Apple Store close by?
Adramalech is offline   Reply With Quote
Old 03-23-2012, 09:12 PM   #4
dmw16
Diamond Member
 
Join Date: Nov 2000
Posts: 7,595
Default

Would it thinking I have something else plugged in cause it totally grey out the controls as opposed to just not causing the iMac internal speakers to put out audio?

I have an Apple store fairly close by but lugging my 27" iMac in is a fairly big task. Plus it isn't s problem I've yet been able to consistently replicate.
__________________
My Heatware
dmw16 is offline   Reply With Quote
Old 03-23-2012, 10:23 PM   #5
Adramalech
Member
 
Adramalech's Avatar
 
Join Date: Aug 2010
Location: Honolulu, HI
Posts: 168
Default

One more bizarre question, is there a red light that is coming on inside of the audio jack? (Optical Out possibly turning itself on.)
Adramalech is offline   Reply With Quote
Old 03-24-2012, 07:58 AM   #6
dmw16
Diamond Member
 
Join Date: Nov 2000
Posts: 7,595
Default

Quote:
Originally Posted by Adramalech View Post
One more bizarre question, is there a red light that is coming on inside of the audio jack? (Optical Out possibly turning itself on.)
Funny you say that because I swore I saw a red light coming out of jack but didn't think much of it. Now it isn't there, but the audio is also working.
__________________
My Heatware
dmw16 is offline   Reply With Quote
Old 03-24-2012, 11:36 AM   #7
KeithP
Diamond Member
 
KeithP's Avatar
 
Join Date: Jun 2000
Location: Sacramento
Posts: 4,231
Default

Quote:
Originally Posted by ChAoTiCpInOy View Post
Might be something is making the iMac think that an optical cable is plugged in. Check your audio settings.
Agreed. Check the settings in Audio MIDI Setup.

-KeithP
__________________
Heat 64-0-0

Hoodies don't have zippers, chili doesn't have beans, the plane won't take off...deal with it.
KeithP is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.