Go Back   AnandTech Forums > Software > Operating Systems

· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· AMD Video Cards
· Nvidia
· Displays
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Home and Garden
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2015
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions

Thread Tools
Old 03-22-2012, 11:29 AM   #1
Diamond Member
Chiropteran's Avatar
Join Date: Nov 2003
Location: Arlington VA
Posts: 8,058
Default Don't "Automatically Detect Settings"!

Internet Explorer> Internet Options> Connections> LAN Settings> Uncheck the "Automatically detect settings" box

It is checked by default on a new install of Windows 7.

Why? I noticed a brief hesitation when opening a browser before it would load my homepage. It wasn't crazy long, but there was a 1-3 second pause before anything happened and I've had much slower computers work faster, so I knew something was up. I did a little googling and found this key bit of info.

Basically with "automatically detect settings" enabled, Windows will try to "detect" your internet connection settings every time you start a new browser session. This wastes valuable time, because if you are on a desktop PC at home your connection settings are probably never going to change, ever.

Note that this settings is not just for internet explorer, it effects other browsers as well, Chrome in particular, as my main browser and where I noticed the issue.
Chiropteran is offline   Reply With Quote
Old 03-22-2012, 11:56 AM   #2
Diamond Member
Chiefcrowe's Avatar
Join Date: Sep 2008
Posts: 4,148

hmm, have not noticed any slowdowns but i will check to see what my settings are
Chiefcrowe is offline   Reply With Quote
Old 03-22-2012, 12:12 PM   #3
Super Moderator
Elite Member
JackMDS's Avatar
Join Date: Oct 1999
Posts: 27,367

If you have e regular setting of Internet feed with a Modem-Router and regular Ethernet (or and you are using common WIFI connection) leave this menu alone (everything unchecked) it a "relic" for old days (or unusual) "primitive" Internet connection.

JackMDS is online now   Reply With Quote
Old 03-23-2012, 07:54 AM   #4
Diamond Member
Chiropteran's Avatar
Join Date: Nov 2003
Location: Arlington VA
Posts: 8,058

Just to be clear- the default on a new install of windows 7 enterprise 64 bit sp1 has this setting enabled. I am assuming other flavors of win 7 are the same. So for best results you need to manually go in and uncheck it.

Sent from my DROID BIONIC using Tapatalk
Chiropteran is offline   Reply With Quote
Old 03-23-2012, 09:12 AM   #5
Elite Member
Nothinman's Avatar
Join Date: Sep 2001
Posts: 30,672

That's for WPAD but it shouldn't take 3s for it to figure out it doesn't exist, I'm thinking it should just be a DNS lookup for wpad.whatever which should take a few ms but it's been a while since I've messed with WPAD so I'm not 100% sure right now.
Nothinman is offline   Reply With Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 01:49 PM.

Powered by vBulletin® Version 3.8.8 Alpha 1
Copyright ©2000 - 2015, vBulletin Solutions, Inc.