Go Back   AnandTech Forums > Hardware and Technology > Computer Help

Forums
· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Home and Garden
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2014
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions
   

Reply
 
Thread Tools
Old 11-03-2009, 01:37 PM   #1
Kadence
Senior Member
 
Join Date: Nov 2004
Posts: 264
Default Vista: Disabling "Restart your computer to finish installing important updates"

I'd like to disable the restart computer message after Windows updates in Vista. I have to keep selecting '4 hours'.

In gpedit.msc I have Re-prompt for restart with scheduled installations enabled and No auto-restart for scheduled Automatic Update installation enabled and set to the max setting of 1440. The above message still pops up every 4 hours.

I don't want to disable updates automatically, but would like to get rid of this message. On googling I read about some software called "Postpone Restart" that's supposed to automatically press this message, but I don't know if that's safe. Is there a way within Vista to get rid of this message?
__________________
Windows Vista 64 - Asus P5E Deluxe X48 - Intel Q9650 E0 - OCZ Platinum DDR2-1066 8GB - Sapphire HD7950 - Antec Twelve Hundred case - Corsair RM850 power supply - 24" HP w2408h monitor
Kadence is offline   Reply With Quote
Old 11-03-2009, 04:13 PM   #2
mpilchfamily
Diamond Member
 
mpilchfamily's Avatar
 
Join Date: Jun 2007
Posts: 3,559
Default

The message shows because the updates installed require a restart to make the updates active. There isn't a way to shut that off since its a required action. If you don't want to encouter it then you need to set up auto update to check for updates durrings times your not normaly at your PC. Then the update can do its thing and the system will automaticly restart for you.
mpilchfamily is offline   Reply With Quote
Old 11-03-2009, 09:57 PM   #3
sivart
Golden Member
 
sivart's Avatar
 
Join Date: Oct 2000
Location: Round Rock, TX
Posts: 1,787
Default

...or just have Vista download the updates and let you manually install them. You can then install them right before you walk away from the computer.

I have both of my Vista machines (both HTPC's) to never check for updates because I get tired of them coming out of sleep mode in the middle of the night and then staying awake...they are worse than a kid on Christmas morning
__________________
Heatware | eBay
sivart is offline   Reply With Quote
Old 04-29-2010, 05:11 PM   #4
Gew
Junior Member
 
Gew's Avatar
 
Join Date: Dec 2009
Location: Kingston, Jamaica.
Posts: 6
Cool

Still no new solution on this one, to get rid of the annoying reminder?
Windows 7 is where the situation is currently at.
Gew is offline   Reply With Quote
Old 04-29-2010, 05:58 PM   #5
RebateMonger
Super Moderator
Elite Member
 
RebateMonger's Avatar
 
Join Date: Dec 2005
Location: Tempe, Arizona, USA
Posts: 11,592
Default

Quote:
Originally Posted by sivart View Post
...or just have Vista download the updates and let you manually install them. You can then install them right before you walk away from the computer.
Yeah, if you are going to shut down your PC each evening, then choosing the "let Windows automatically download, but not install" option is probably best for your needs. When you shut down, Windows will offer the option to install Updates and then shut itself down.

I don't know if the problem ever comes up with desktops, but I've definitely seen cases where Windows Server HAD to be restarted before the Server would function correctly. MS sometimes would disable services to perform the update and things wouldn't behave right until the system was rebooted.
__________________
MCSE:Security:2003 - MCTS:SBS 2008 - Arizona's 1st Microsoft Small Business Specialist
--- In loving memory of my beautiful Australian Shepherd, Skye. July 2001-January 2010 ---
War on Terror 2000-2010 ~ Terrorist-caused Deaths < 10,000 ~ Bush's Wars > 1,000,000 ~ Winning?
RebateMonger is offline   Reply With Quote
Old 04-29-2010, 06:03 PM   #6
corkyg
Moderator
Peripherals
 
corkyg's Avatar
 
Join Date: Mar 2000
Location: Tucson, Arizona
Posts: 24,307
Default

The reboot causes entries to the Registry to be active, ergo, it is essential to do it. Your best choice would be download but not install. Then you are in control.

You get rid of the message by rebooting.

BTW - those update reboots are phased and OS controlled, and should not be interrupted.
__________________
CorkyG - Tucson, AZ

“Excuses are the nails used to build a house of failure” - Don Wilder

Last edited by corkyg; 04-29-2010 at 06:05 PM.
corkyg is offline   Reply With Quote
Old 07-10-2013, 08:24 PM   #7
timtak
Junior Member
 
Join Date: Jul 2013
Posts: 2
Default

Quote:
Originally Posted by RebateMonger View Post
choosing the "let Windows automatically download, but not install" option is probably best for your needs.
I do shut my computer down each evening, so this would be the ideal behaviour (is any update so urgent that it needs to be installed during the same day that it is put out?) but I do not know where to find this option. I have Googled the quoted phrase above but the only hit is here.

I have heard rumour that it is settable in something called "local group policy options/settings" (I am back translating from Japanese since mine is a Japanese windows 7) but I can't find "local group policy options."

I have heard that local group policy options is not available on all versions of Windows 7. I have Widows 7 Home Premium, and perhaps this is not enough.

I find that after four hours has elapsed a popup is displayed saying "reboot now?" or some such, but this popup steals focus (is that what it's called).

I am using two screens, so if I am typing in the other screen, and do not notice that the popup has popped up in the other screen, and then press enter with the intention that this is part of what I am typing in the other screen, then since the popup has stolen focus, Windows takes this enter to mean that I do want to reboot immediately and reboots without saving any of my work in progress. This has happened to me twice

For the time being I am using Start -> Run -> services.msc -> Windows Update [right click] Stop

If possible I would be grateful of instruction on how to select the option mentioned at the beginning of this post.

Tim
timtak is offline   Reply With Quote
Old 07-10-2013, 10:29 PM   #8
Bubbaleone
Golden Member
 
Bubbaleone's Avatar
 
Join Date: Nov 2011
Posts: 1,690
Default

Quote:
Originally Posted by timtak View Post

If possible I would be grateful of instruction on how to select the option mentioned at the beginning of this post.

Tim
Welcome to the forums! Re-enable the Windows Update service, then click the 'Start' button, click 'All Programs', click 'Windows updates' and, in the upper left hand corner of the dialog, click 'Change settings'. Under 'Important updates', click 'Please select an option', then select either 'Download updates but let me choose whether to install them' or 'Check for updates but let me choose whether to download and install them'.

.
__________________
ASRock Z77 Extreme9 | i7-3770K@4.6GHz | 32GB Corsair Dominator Platinum | Corsair H100i
2 x RAID 10 Samsung 840 Pro Series MZ-7PD256BW | 4 x RAID 10 WD 2TB RE WD2000FYYZ
2 x MSI R7950 Twin Frozr 3GD5/OC XFire | HP ZR2440w IPS
Lian Li PC-7HX Black Aluminum | XFX ProSeries P1-1000-BELX | HEAT
Bubbaleone is online now   Reply With Quote
Old 07-10-2013, 10:37 PM   #9
timtak
Junior Member
 
Join Date: Jul 2013
Posts: 2
Default

Quote:
Originally Posted by Bubbaleone View Post
Welcome to the forums! Re-enable the Windows Update service, then click the 'Start' button, click 'All Programs', click 'Windows updates' and, in the upper left hand corner of the dialog, click 'Change settings'. Under 'Important updates', click 'Please select an option', then select either 'Download updates but let me choose whether to install them' or 'Check for updates but let me choose whether to download and install them'.

.
Than you very much indeed. I could not find Windows Update in the programs menu but I found it in the control panel and chose 'Download updates but let me choose whether to install them'

Great! No more lost work. I understand that I will be give the option to install when i shutdown. This is just what I want.

I wonder if changing this setting will be enough to put a stop to the four hour time bomb or whether I should turn off Windows Update service for today. The prompt is back so I am just going to restart my computer.

Thanks again,

Tim

Last edited by timtak; 07-10-2013 at 10:49 PM.
timtak is offline   Reply With Quote
Old 07-11-2013, 10:21 AM   #10
kalrith
Diamond Member
 
kalrith's Avatar
 
Join Date: Aug 2005
Location: Missouri
Posts: 6,586
Default

Quote:
Originally Posted by timtak View Post
Than you very much indeed. I could not find Windows Update in the programs menu but I found it in the control panel and chose 'Download updates but let me choose whether to install them'

Great! No more lost work. I understand that I will be give the option to install when i shutdown. This is just what I want.

I wonder if changing this setting will be enough to put a stop to the four hour time bomb or whether I should turn off Windows Update service for today. The prompt is back so I am just going to restart my computer.

Thanks again,

Tim
If you've already installed the updates and don't want the restart prompt, then yes, you'll have to disable the Windows Update service.

In the future, don't install the updates unless you want to deal with the restart prompt. I would recommend just waiting until you're ready to shut down and choosing the shut down and install updates option.
__________________
Heatware 24+ eBay 22+
kalrith is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.