Go Back   AnandTech Forums > Hardware and Technology > Motherboards

Forums
· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Home and Garden
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2014
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions
   

Reply
 
Thread Tools
Old 08-11-2006, 09:52 PM   #1
saabman
Member
 
Join Date: Apr 2006
Posts: 73
Default Turn Off PXE Boot function

I have a P3 Intel 815e chipset MB (Tyan S2425) that automatically wants to boot thru PXE and no matter how I answer the config screen (CTRL S) for local boot options, it never saves my changes.

This is based on Intel Boot Agent version 2.6.004 (ICH2 TEST).

I go into the BIOS and change the boot device order, but it doesn't make a difference.

Is there any way to disable PXE?

I can't find a BIOS entry that disables this.

Hope someone can help me.
saabman is offline   Reply With Quote
Old 08-12-2006, 06:05 AM   #2
Peter
Elite Member
 
Join Date: Oct 1999
Posts: 9,640
Default Turn Off PXE Boot function

You end up in the PXE boot client because your local boot drives didn't WORK. What you actually need to do is fix whatever problem your local drives have.
Peter is offline   Reply With Quote
Old 08-12-2006, 01:02 PM   #3
tcsenter
Lifer
 
tcsenter's Avatar
 
Join Date: Sep 2001
Location: Central California
Posts: 17,098
Default Turn Off PXE Boot function

Quote:
Originally posted by: Peter
You end up in the PXE boot client because your local boot drives didn't WORK. What you actually need to do is fix whatever problem your local drives have.
Not necessarily. I have seen a few boards that invoke the PXE boot client every time, the boot client searches for a valid remote server, finds none, then exits and the system proceeds with the boot sequence set in BIOS.

All local drives boot normally, but only after the damned PXE client gets done with its thing and there is nothing in the BIOS that will disable PXE or change its grabbing the top spot in the boot sequence every time.
tcsenter is offline   Reply With Quote
Old 08-12-2006, 01:45 PM   #4
Peter
Elite Member
 
Join Date: Oct 1999
Posts: 9,640
Default Turn Off PXE Boot function

Netboot ROMs either register with BBS, which makes them available to the main BIOS's boot device ordering method, or grab the "boot failure" vector which makes them last.

So if you got the PXE netboot ROM appearing first, then you very probably just haven't found the BIOS setup switch that reorders it to the back of the queue
Peter is offline   Reply With Quote
Old 08-12-2006, 06:11 PM   #5
tcsenter
Lifer
 
tcsenter's Avatar
 
Join Date: Sep 2001
Location: Central California
Posts: 17,098
Default Turn Off PXE Boot function

That's what I'm saying. The BIOS peeps hid the option to disable PXE. The BIOS boot sequence either didn't have an option for BBS or it didn't have any effect when changed, can't remember now.

I haven't seen it a lot, but I've seen it. One of the systems was an older Toshiba Satellite notebook, now that you've stirred my recollection.
tcsenter is offline   Reply With Quote
Old 08-13-2006, 09:22 AM   #6
saabman
Member
 
Join Date: Apr 2006
Posts: 73
Default Turn Off PXE Boot function

Quote:
So if you got the PXE netboot ROM appearing first, then you very probably just haven't found the BIOS setup switch that reorders it to the back of the queue
Yes, I have found both the Boot sequence setting in the BIOS and a separate "CTRL S" Intel Boot Agent PXE setup utlity during the boot process.

I've even removed the network port options completely from the BIOS boot sequence (leaving only HD), as well as moving them to the end of the sequence. Neither made any difference

Neither BIOS boot sequence, nor Intel boot utlity will remove PXE as the first executing boot attempt.

The Intel Boot Agent setup utility allows for toggling a network/local boot option, but when I use the "F4 SAVE" option, it simply ends with a quick message I can't read, but it does appear the word error is part of this message.

It's clear my option changes in the Intel Boot Agent setup utility never get saved, because it always keeps the exact same settings every time I enter this setup utlity.

I'm stumped!

saabman is offline   Reply With Quote
Old 08-13-2006, 12:17 PM   #7
Peter
Elite Member
 
Join Date: Oct 1999
Posts: 9,640
Default Turn Off PXE Boot function

The controls in the Ctrl-S menu are effective only for legacy main BIOSes that do NOT use the BBS architecture for sorting the boot devices. On a halfway recent, BBS-enabled BIOS, this does nothing.
Peter is offline   Reply With Quote
Old 08-13-2006, 01:10 PM   #8
saabman
Member
 
Join Date: Apr 2006
Posts: 73
Default Turn Off PXE Boot function

An Update!!

I've loaded the latest most up-to-date BIOS, dated 05/10/03.

Using a small quickly installed linux (Puppy 2.00) I was able to get the port working temporarily with the following

1) Load the Intel Pro100 8225? linux driver
2) Set for DHCP

3) After the interface comes up, do the following as root
(xx is substituted with the MAC address shown on top of myRJ45 connector)

# ifconfig eth0 down
# ifconfig eth0 hw ether 00:E0:xx:xx:xx:xx
# ifconfig eth0 up

After this I'm able to ping my router, access router's admin page, and use Opera to access the Internet.

The only problem is this address is not saved when I reboot. Now I'm back to the same problem.

Sent an email off to Tyan support for some advice, also hoping someone here has some ideas.

Thinking about the MB battery, but the date and time in Bios seems to be fine even when I disconnect power supply, so doesn't seem like a failed battery.


saabman is offline   Reply With Quote
Old 08-13-2006, 01:22 PM   #9
Peter
Elite Member
 
Join Date: Oct 1999
Posts: 9,640
Default Turn Off PXE Boot function

Does the PXE client not report a correctly programmed MAC address, or why are you manually programming one?
Peter is offline   Reply With Quote
Old 08-13-2006, 03:05 PM   #10
saabman
Member
 
Join Date: Apr 2006
Posts: 73
Default Turn Off PXE Boot function

Quote:
Originally posted by: Peter
Does the PXE client not report a correctly programmed MAC address, or why are you manually programming one?

Peter,
I'm actually not trying to use PXE (no PXE server), I've just found no way to turn PXE off, because the CTRL S setup utility won't allow me to toggle the default to local boot instead of network boot.

I want to use both ethernet ports as part of a firewall (m0n0wall) based on freeBSD.
Because MAC address ff:ff:ff. . . . is actually a broadcast address, it doesn't work as a node address for connection to the DSL router (or to the internal LAN either for that matter).

I don't know enough about PXE to know if the ff:ff:. . . MAC address is a normal configuration for a dual-port onboard ethernet implementation.

I was just trying to turn PXE off so I can use both onboard ethernet ports with the m0n0wall software. This software lists both eth0 and eth1 ethernet interface ports, but lists the eth0 port with the ff:ff;ff: . . . MAC adress port as invalid and not available.

saabman is offline   Reply With Quote
Old 08-13-2006, 05:06 PM   #11
Peter
Elite Member
 
Join Date: Oct 1999
Posts: 9,640
Default Turn Off PXE Boot function

I'm just asking what MAC address the PXE client displays because this being FF:FF:... would be an indication that the ethernet chip's configuration EEPROM is fvcked. That in turn would be a support case for the maker of the board it's on. The ethernet EEPROM of Intel ethernet chips can be reprogrammed in-place, but for that you'll need (a) the MAC address it's supposed to have and (b) the utility program to put it back in.
The Ctrl-S menu not letting you disable the PXE client from registering with the main BIOS may very well also be a symptom of the bad EEPROM contents.
Peter is offline   Reply With Quote
Old 08-13-2006, 11:40 PM   #12
saabman
Member
 
Join Date: Apr 2006
Posts: 73
Default Turn Off PXE Boot function

Peter,
Understood. PXE only shows the ff:ff:ff:ff:ff:ff MAC address. All of the various software utilities I've used (XP and linux) show this same MAC address for this port.

I was just asking if the standard configuration for a PXE dual onboard ethernet motherboard was one port with a regular MAC address and one with this universal broadcast MAC address. I've never worked with PXE before.

I finally got a workaround. m0n0wall has a MAC address spoofer in the WAN setup subsection where I'm able to enter the actual MAC address that is written on the metal top of the RJ45 connector.

I would still like to know what utility software is used to flash the MAC address on the MB's EEPROM in place. Both ports are Intel ethernet chips. One via an 82599 controller and one via the chipset ICH2 (8252EM).

saabman is offline   Reply With Quote
Old 08-14-2006, 04:08 AM   #13
Peter
Elite Member
 
Join Date: Oct 1999
Posts: 9,640
Default Turn Off PXE Boot function

With the EEPROM empty, you've not only lost the MAC address, but also a handful more items of the ethernet chip's hardware setup - so the utility program alone won't help. You'll need the initialization file from your board maker. The one thing left to do for you is figure out which one of the two has lost its brain.
Peter is offline   Reply With Quote
Old 08-14-2006, 08:13 AM   #14
saabman
Member
 
Join Date: Apr 2006
Posts: 73
Default Turn Off PXE Boot function

When selecting drivers in one of my linux test sessions, I used (selected) two different drivers for the nics:

1) eePro100 driver for the Intel Pro100 82599 nic, identified as 82559 in the BIOS

2) e100 driver for the ICH2 8252EM nic, identified as ICH2 in the BIOS

I've also identified the physical MB location of each RJ45 connector and their corresponding MAC address.

Is there anything else I need to identify, besides the program and initialization file from TYAN?

Quote:
With the EEPROM empty, you've not only lost the MAC address, but also a handful more items of the ethernet chip's hardware setup - . . .
Could you be more specific? It seems to be running just fine, but I'd like to be aware of any pending problems.


saabman is offline   Reply With Quote
Old 08-14-2006, 08:55 AM   #15
Peter
Elite Member
 
Join Date: Oct 1999
Posts: 9,640
Default Turn Off PXE Boot function

Some other settings, like connector type (optical or copper), status LED wiring, boot settings (see?), subtleties of PCI bus behavior, are also set from that EEPROM.

As far as I recall, you should use the e100 driver for both. (There is no "599" chip actually, 559 is probably correct.)
Peter is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.