Go Back   AnandTech Forums > Hardware and Technology > Computer Help

Forums
· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Home and Garden
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2014
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions
   

Reply
 
Thread Tools
Old 10-26-2013, 05:14 AM   #1
Sithtiger
Member
 
Join Date: Apr 2005
Posts: 175
Question Getting Kicked to Desktop While Playing Games Like SWTOR......

So I have an application I believe that is kicking me out of games...well I only play 2, Star Wars: The Old Republic and Battlefield 3. When I'm playing SWTOR, it kicks me out to the desktop. Let me be clear though, it's not crashing, because I can get back into the game by clicking on the icon or clicking Alt+Tab. Now, the only thing I've installed was Ninite. For those that don't know, Ninite is an open source app that will update all the selected programs for you and of those programs, these are the ones that I asked it to update. Firefox, Chrome, Silverlight, Air, Java, Java x64, Shockwave, uTorrent, 7-Zip, Steam, Auslogics, Skydrive, VLC, Spotify, Google Drive, Dropbox, Evernote, iTunes, .NET, Google Earth, Malwarebyte, Ad-Aware and Spybot 2.

I made sure that I turned off any automatic scanning from them, but I'm still getting kicked to the desktop when playing SWTOR. When I play Battlefield 3, it's as if it tries to kick me, but it blacks out only for a second and then comes back to the game. It's REALLY annoying especially when playing SWTOR, because the game is so huge that even my rather speedy computer takes a few seconds to load back. It's do or die when playing PvP in SWTOR and something like that means that you will die if you're playing PvP.

I don't know what else it could be, because these are the programs (actually Ninite) was installed prior to this happening. I actually had this problem prior to this with SWTOR, but this only happened once in a while and by that I mean maybe once a week so no biggie. Now, this happens about every 30 minutes or so. I'm just guessing.

If I knew of the offending program, I would either disable or uninstall it. I've looked at Task Manager and can't find which one it is, because TM doesn't show it as an application running. That said, I'm sure there is a process running for it, but I don't know what it is. It's not as if I can look in the logs because it's not an error. Does anyone have any ideas how to identify the offending program?

BTW, I've gone into MSCONFIG and disabled everything except the essential programs like Antivirus, keyboard and mouse support etc. I don't even have Ad-Aware or Spybot starting, and those services are set to manual, but it does seem logical that it's one of them.

TL;DR: I get kicked to the desktop while playing SWTOR and can't figure out what program is causing it.

Thanks in advance!

Tech Support Guy System Info Utility version 1.0.0.2
OS Version: Microsoft Windows 7 Home Premium, Service Pack 1, 64 bit
Processor: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz, Intel64 Family 6 Model 58 Stepping 9
Processor Count: 4
RAM: 16337 Mb
Graphics Card: NVIDIA GeForce GTX 670, -2048 Mb
Hard Drives: C: Total - 476937 MB, Free - 28699 MB; E: Total - 953866 MB, Free - 12541 MB;
Motherboard: MSI, Z77A-G45 (MS-7752)
Antivirus: Norton Internet Security, Updated and Enabled
__________________
Core i5-3570K CPU / MSI, Z77A-G45 Motherboard / 16GB 4x4GB of PC3-12800U DDR3 G.Skill RAM / EVGA GeForce GTX 670 SC Video Card / Western Digital 1TB HD/Western Digital 500GB HD / Lite-On 16X Dual Layer SOHW-1693S Burner / Corsair HX850 850 watt PSU / Windows 7 x64
Sithtiger is offline   Reply With Quote
Old 10-26-2013, 09:47 AM   #2
Matt1970
Lifer
 
Matt1970's Avatar
 
Join Date: Mar 2007
Location: Syracuse NY
Posts: 11,356
Default

You aren't accidentally hitting the start menu key are you?
Matt1970 is offline   Reply With Quote
Old 10-26-2013, 11:41 AM   #3
Steltek
Golden Member
 
Join Date: Mar 2001
Posts: 1,505
Default

You might try swapping out your keyboard.

If you have one or more worn keyswitches, pushing those keys in tandem might be putting out a signal that the system interprets as WIN+M or WIN+D (both of which will minimize all running applications to the desktop).

You can disable the hotkeys to test it out:

http://www.sevenforums.com/tutorials...e-disable.html
Steltek is offline   Reply With Quote
Old 10-30-2013, 05:21 AM   #4
Sithtiger
Member
 
Join Date: Apr 2005
Posts: 175
Default

Quote:
Originally Posted by Matt1970 View Post
You aren't accidentally hitting the start menu key are you?
Lol, no I'm not. It will do this when I'm not even hitting any keys actually.

Quote:
Originally Posted by Steltek View Post
You might try swapping out your keyboard.

If you have one or more worn keyswitches, pushing those keys in tandem might be putting out a signal that the system interprets as WIN+M or WIN+D (both of which will minimize all running applications to the desktop).

You can disable the hotkeys to test it out:

http://www.sevenforums.com/tutorials...e-disable.html
Thanks, I'll try disabling the hotkeys, but like I stated above, it will do this when I'm not even touching anything. As of recently, it sometimes will do this when I just get into the game. I don't think it's the keys, but I'll still disable them and see what happens.

Thanks to both of you. I'll try this and report back.
__________________
Core i5-3570K CPU / MSI, Z77A-G45 Motherboard / 16GB 4x4GB of PC3-12800U DDR3 G.Skill RAM / EVGA GeForce GTX 670 SC Video Card / Western Digital 1TB HD/Western Digital 500GB HD / Lite-On 16X Dual Layer SOHW-1693S Burner / Corsair HX850 850 watt PSU / Windows 7 x64
Sithtiger is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.