Go Back   AnandTech Forums > Hardware and Technology > Networking

Forums
· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2013
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions
   

Reply
 
Thread Tools
Old 02-08-2013, 11:40 AM   #1
jibs
Member
 
Join Date: Jul 2011
Location: Canada
Posts: 105
Default Moved to new city, DNS problems?

Hello, I recently moved to a new city and province (canadian) and when I setup my computers/networking equipment I was getting an error saying that my computers were connected to my network, but unable to access the internet and they were unable to communicate with each other. I have since found a way to make everything work, but I would like to learn what caused this and if there is a better way to fix it than what I did.

Here's a bit about my setup:

1 x Linksys E2000 wireless router
2 x Win 7 pro Desktops
2 x Win 7 pro laptops
1 x imac, no problem on the OSX side, just the Win 7 pro side
1 x qnap ts-212 NAS
1 x iphone

Before I moved I had it setup so all the computers could communicate with each other and access the NAS. The NAS has a static IP address and uses googles public dns servers. My personal desktop has a static IP address and was using dns settings that I must have got from my ISP. The NAS and my personal desktop were both hardwired. All of the other devices were connected with wireless and would have IP addresses assigned to them by the router. We have stayed with the same ISP provider and when we moved into our new house, I connected everything the exact same way.

We got a new cable modem from our ISP, I plugged it into the wireless router and connected my personal desktop and the NAS directly to it and they both worked right away and could communicate with each other and access the internet.

I connected my iphone and was able to access the internet and via the qnap app, communicate with the NAS. When I connected all of the other computers to the wifi, they would connect to the network, but be unable to access the internet and they wouldn't be able to communicate with any of the other devices on the network. Checkout out their IP addresses they were all being assigned IP's that started with 192.168.100.xxx, which I didn't understand since my hardwired machines were all statically assigned 192.168.1.xxx. After doing the basic trouble shooting I could think of (ipconfig /release, /flushdns, /renew) I decided to assign them all static IP's and assign them the DNS settings from my router. After making these changes all the machines started working and could access the internet and communicate with each other on the network.

I just connected my work laptop to the network (wired) and had to go in and assign it a static IP and DNS settings to get it to work.

I have power cycled my modem and router, i don't want to reset my router since there are some port forwarding settings enabled for the NAS that i don't really want to redo.

I'm wondering if the way I solved this problem is the best way possible? I would like my router to automatically assign proper IP's to devices connected to my network, i don't want to have to assign everything a static IP address. Why is my router assigning my computers IP addresses that can't be used to access the internet?

Sorry for the long post, hopefully my ramblings make sense. Thanks in advance for the help

Jibs
jibs is offline   Reply With Quote
Old 02-08-2013, 12:52 PM   #2
owensdj
Golden Member
 
Join Date: Jul 2000
Posts: 1,600
Default

It could be that the new cable modem from your ISP has a built-in router that's assigning IP addresses to devices. Some devices are getting their IP address on the 192.168.1.x subnet from the wireless router but others are getting an IP address on the 192.168.100.x subnet from the cable modem.

You should go into the setup for the Linksys E2000 wireless router and verify it's IP address. By default it should be 192.168.1.1.

What's the model of the cable modem?
__________________
Intel Core i7-3770 3.4GHz | Gigabyte GA-Z77MX-D3H | G.Skill 8GB (2x4GB) DDR3 1600 | Western Digital Caviar Black 1.5TB | Asus 24x DVD Burner | Hauppauge WinTV-HVR-2250 | PC Power & Cooling Silencer MK III 500W PSU | Cooler Master HAF 912 Case | Windows 7 Pro

Last edited by owensdj; 02-08-2013 at 12:57 PM.
owensdj is offline   Reply With Quote
Old 02-08-2013, 01:28 PM   #3
dawks
Diamond Member
 
Join Date: Oct 1999
Posts: 5,028
Default

I assign everything DNS from a 3rd party server. ISP's DNS is usually minimally maintained. Just a box somewhere that only receives attention when it crashes.

Try OpenDNS (more secure, reliable, and has features that allow you to block categories of sites)
208.67.222.222
208.67.220.220

Google DNS
8.8.8.8
8.8.4.4

Verizon / Level3 (I find these to be very fast for me)
4.2.2.2
4.2.2.3
4.2.2.4
4.2.2.5
4.2.2.6

I actually use about 4-5 of these sometimes, that helps get me the widest/most reliable coverage.
Also, don't use your router as a DNS server. I know some routers will hand out their own IP as the DNS server and forward requests. Its just an extra unnecessary layer.
dawks is offline   Reply With Quote
Old 02-08-2013, 02:05 PM   #4
jibs
Member
 
Join Date: Jul 2011
Location: Canada
Posts: 105
Default

Thanks for the information.

Owensdj: How would I know if the router is handing out DNS addresses. The E2000's IP address is 192.168.1.1. The model# of the cable modem is Motorola SB5102

Dawks: So how would I go about making the switch from using my router for my DNS. Looking at the routers control panel i'm not sure what steps I would take to turn off its DNS settings. Also if I did that would I have to manually assign the DNS addresses to all new and existing devices?

Thanks again for the help
jibs is offline   Reply With Quote
Old 02-08-2013, 06:10 PM   #5
owensdj
Golden Member
 
Join Date: Jul 2000
Posts: 1,600
Default

I looked up the user guide for your cable modem. It doesn't have a built-in router like I thought it might, so it won't be handing out IP addresses. I assume you have your modem plugged into the "Internet" port on your router?

As far as DNS, you'll want to set your two DNS server addresses in your router so it will tell all of your client machines to use them when they get their IP addresses from the router. Pick either the Google ones or the OpenDNS ones. Find DHCP Server Setting in your router's browser-based setup. Put in the two DNS server addresses under Static DNS1 and Static DNS 2.

Are you sure your wireless clients aren't connecting to a neighbor's open wi-fi by mistake? That would explain how they ended up on the wrong subnet.
__________________
Intel Core i7-3770 3.4GHz | Gigabyte GA-Z77MX-D3H | G.Skill 8GB (2x4GB) DDR3 1600 | Western Digital Caviar Black 1.5TB | Asus 24x DVD Burner | Hauppauge WinTV-HVR-2250 | PC Power & Cooling Silencer MK III 500W PSU | Cooler Master HAF 912 Case | Windows 7 Pro

Last edited by owensdj; 02-08-2013 at 06:59 PM.
owensdj is offline   Reply With Quote
Old 02-09-2013, 09:58 AM   #6
jibs
Member
 
Join Date: Jul 2011
Location: Canada
Posts: 105
Default

Yeah the modem is plugged into the "internet" port on my router. I have setup the Static DNS1 and DNS2 on my router to use the open DNS addresses. I noticed something last night while looking at the routers config, it said "start ip address 192.168.100.1 to 149" before I made the changes. Since making the DNS changes its now showing "start ip address 192.168.1.100 to 149". I'm not sure why its starting at 100, but that's alright since I don't need anymore than 10 ip addresses.

When I was initially trouble shooting my wireless client i cleared all the old wireless networks from the wireless history to make sure i wasn't accidentally connecting to someone else's wifi. I'm not sure what was going on with them but they appear to be working properly now.

Thanks for all the help
jibs is offline   Reply With Quote
Old 02-09-2013, 11:34 AM   #7
owensdj
Golden Member
 
Join Date: Jul 2000
Posts: 1,600
Default

That DHCP range you had initially of 192.168.100.1 to .149 sounds wrong. That would mean the router was giving out its own IP address of 192.168.100.1 to clients. .100 to 149 should have been the router's default DHCP range.
__________________
Intel Core i7-3770 3.4GHz | Gigabyte GA-Z77MX-D3H | G.Skill 8GB (2x4GB) DDR3 1600 | Western Digital Caviar Black 1.5TB | Asus 24x DVD Burner | Hauppauge WinTV-HVR-2250 | PC Power & Cooling Silencer MK III 500W PSU | Cooler Master HAF 912 Case | Windows 7 Pro
owensdj is offline   Reply With Quote
Old 02-09-2013, 04:33 PM   #8
jibs
Member
 
Join Date: Jul 2011
Location: Canada
Posts: 105
Default

I'm still having some problem, i removed all the wireless networks from one of my laptops, changed the settings to automatically obtain an IP and DNS settings and it was still given an IP address it couldn't use. I have take a screenshot of my routers configuration, is there something i'm misssing?




jibs is offline   Reply With Quote
Old 02-09-2013, 04:43 PM   #9
AnonymouseUser
Diamond Member
 
AnonymouseUser's Avatar
 
Join Date: May 2003
Location: Dallas TX
Posts: 8,357
Default

What about the DHCP Reservation?

Backup the configuration and reset your router. If it works properly after that then there's something wrong with your router configuration. You can always restore the original configuration if you want.
__________________
NSA Homeland Security PRISM Denial of service Malware Trojan Keylogger Cyber Command
2600 Backpack Phishing Rootkit Agro Eco terrorism Conventional weapon
Target Weapons grade Dirty bomb Enriched Nuclear Chemical Biological weapon Black out
Pressure Cooker Grid Power Smart Body scanner Electric Failure Ammonium nitrate Brown Out
Bridge Organized crime National security State emergency Security Breach Threat Standoff
SWAT Screening Virus Environmental Terrorist Dock
AnonymouseUser is offline   Reply With Quote
Old 02-09-2013, 05:49 PM   #10
owensdj
Golden Member
 
Join Date: Jul 2000
Posts: 1,600
Default

That part of your router config looks correct.

Did you check to see if your wireless clients might be connecting to a neighbor's wireless network by mistake?

Could you show us a screenshot of you running "ipconfig /all" on the laptop?
__________________
Intel Core i7-3770 3.4GHz | Gigabyte GA-Z77MX-D3H | G.Skill 8GB (2x4GB) DDR3 1600 | Western Digital Caviar Black 1.5TB | Asus 24x DVD Burner | Hauppauge WinTV-HVR-2250 | PC Power & Cooling Silencer MK III 500W PSU | Cooler Master HAF 912 Case | Windows 7 Pro
owensdj is offline   Reply With Quote
Old 02-09-2013, 07:34 PM   #11
jibs
Member
 
Join Date: Jul 2011
Location: Canada
Posts: 105
Default

Here is my laptop ipconfig /all on my working connection with static IP and open DNS:

Windows IP Configuration
Host Name . . . . . . . . . . . . : Laptop
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
Physical Address. . . . . . . . . : XX-XX-XX-9A-22-97
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) WiFi Link 5300 AGN
Physical Address. . . . . . . . . : XX-XX-XX-9A-22-96
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::9d06:63a1:bfcc:439b%15(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.125(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCPv6 IAID . . . . . . . . . . . : 184557930
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-8A-6C-63-00-27-13-66-20-94

DNS Servers . . . . . . . . . . . : 208.67.222.222
208.67.220.220
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
Physical Address. . . . . . . . . : XX-XX-XX-8B-34-50
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : ok.shawcable.net
Description . . . . . . . . . . . : Intel(R) 82567LM Gigabit Network Connecti
on
Physical Address. . . . . . . . . : XX-XX-XX-66-20-94
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{A0185453-CF59-4195-B892-1FFFADEF5B65}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:9d38:953c:18dc:29c1:3f57:fe82(Pref
erred)
Link-local IPv6 Address . . . . . : fe80::18dc:29c1:3f57:fe82%13(Preferred)
Default Gateway . . . . . . . . . : ::
NetBIOS over Tcpip. . . . . . . . : Disabled


Now after I go in and delete my wireless network and any other saved wireless networks. I set the IP and DNS to be obtained automatically and run ipconfig /all again i get this:

Windows IP Configuration
Host Name . . . . . . . . . . . . : Laptop
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
Physical Address. . . . . . . . . : XX-XX-XX-9A-22-97
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) WiFi Link 5300 AGN
Physical Address. . . . . . . . . : XX-XX-XX-9A-22-96
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::9d06:63a1:bfcc:439b%15(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.100.15(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Saturday, February 09, 2013 6:25:40 PM
Lease Expires . . . . . . . . . . : Saturday, February 09, 2013 6:26:27 PM
Default Gateway . . . . . . . . . : 192.168.100.1
DHCP Server . . . . . . . . . . . : 192.168.100.1
DHCPv6 IAID . . . . . . . . . . . : 184557930
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-8A-6C-63-00-27-13-66-20-94

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
Physical Address. . . . . . . . . : XX-XX-XX-8B-34-50
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : ok.shawcable.net
Description . . . . . . . . . . . : Intel(R) 82567LM Gigabit Network Connecti
on
Physical Address. . . . . . . . . : XX-XX-XX-66-20-94
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{A0185453-CF59-4195-B892-1FFFADEF5B65}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes



I'm not too sure what DHCP reservation is, but here is a pic of my routers settings:



I will look into backing up my routers config file and keep that as an option.

Thanks again for all the help
jibs is offline   Reply With Quote
Old 02-09-2013, 09:05 PM   #12
owensdj
Golden Member
 
Join Date: Jul 2000
Posts: 1,600
Default

Your wireless client is getting the wrong IP address for the router, gateway, and DHCP server and has the wrong lease time(unless you changed the default in your E2000). It sounds farfetched, but the only thing I can think of that might cause that is that the wireless client is connecting to a neighbor's wireless network. Have you checked to make sure the laptop is only connecting to your router?

I'm assuming you changed your Linksys E2000 router's wireless SSID to something other than the default and have WPA2 Personal security enabled on it?
__________________
Intel Core i7-3770 3.4GHz | Gigabyte GA-Z77MX-D3H | G.Skill 8GB (2x4GB) DDR3 1600 | Western Digital Caviar Black 1.5TB | Asus 24x DVD Burner | Hauppauge WinTV-HVR-2250 | PC Power & Cooling Silencer MK III 500W PSU | Cooler Master HAF 912 Case | Windows 7 Pro
owensdj is offline   Reply With Quote
Old 02-09-2013, 09:14 PM   #13
jibs
Member
 
Join Date: Jul 2011
Location: Canada
Posts: 105
Default

Unless i'm missing something I'm pretty sure i'm only connecting to my own wifi network







Thanks
jibs is offline   Reply With Quote
Old 02-09-2013, 11:20 PM   #14
AnonymouseUser
Diamond Member
 
AnonymouseUser's Avatar
 
Join Date: May 2003
Location: Dallas TX
Posts: 8,357
Default

Is it possible that your cable modem is also providing the DHCP addresses? This is called Double NAT, and to fix it you need to put the modem in "bridge mode".

EDIT>>

Quote:
Originally Posted by owensdj View Post
I looked up the user guide for your cable modem. It doesn't have a built-in router like I thought it might, so it won't be handing out IP addresses. I assume you have your modem plugged into the "Internet" port on your router?
owensdj already suggested this, but I think he may be wrong about the modem having routing capability. On page 29 of the user manual, it says the modem supports up to 63 devices and shows a diagram using a crossover cable and hub or switch. Unfortunately, I don't see how to put the modem into bridge mode, so it may not be possible to turn the DHCP server off on the modem. You may need a new modem.
__________________
NSA Homeland Security PRISM Denial of service Malware Trojan Keylogger Cyber Command
2600 Backpack Phishing Rootkit Agro Eco terrorism Conventional weapon
Target Weapons grade Dirty bomb Enriched Nuclear Chemical Biological weapon Black out
Pressure Cooker Grid Power Smart Body scanner Electric Failure Ammonium nitrate Brown Out
Bridge Organized crime National security State emergency Security Breach Threat Standoff
SWAT Screening Virus Environmental Terrorist Dock

Last edited by AnonymouseUser; 02-09-2013 at 11:32 PM.
AnonymouseUser is offline   Reply With Quote
Old 02-10-2013, 08:48 AM   #15
owensdj
Golden Member
 
Join Date: Jul 2000
Posts: 1,600
Default

AnonymouseUser, you could be right, but my understanding of the modem was that it could give out multiple *public* IP addresses, not do NAT because the manual says, "Not all service providers support multiple user service." In any case, I don't see how the client machines could get an IP address from a device plugged into the Internet port on the router.

Jibs, I assume the cable modem is plugged into the "Internet" port on the router, not one of the ports of the router's switch?
__________________
Intel Core i7-3770 3.4GHz | Gigabyte GA-Z77MX-D3H | G.Skill 8GB (2x4GB) DDR3 1600 | Western Digital Caviar Black 1.5TB | Asus 24x DVD Burner | Hauppauge WinTV-HVR-2250 | PC Power & Cooling Silencer MK III 500W PSU | Cooler Master HAF 912 Case | Windows 7 Pro
owensdj is offline   Reply With Quote
Old 02-10-2013, 11:54 AM   #16
jibs
Member
 
Join Date: Jul 2011
Location: Canada
Posts: 105
Default

Well calling my ISP was an interesting experience, I got 1 person who was more than willing to help me and starting looking into the problem, came back and said they found something similar on a wrt54g forum and as soon as they said that my chat session was disconnected and the windows closed so i wasn't able to see what they were talking about or get the link from them. I started a new chat and got some dude who told me he couldn't help me. The first rep did say that she didn't think the cable modem could act as a dhcp server.

Yeah the cable modem is plugged into the "internet" port on my router, then my computers are either plugged into the router or connected with wifi.

With my laptop connected to the incorrect IP address of 192.168.100.15, i tried to go the default gateway of 192.168.100.1 and I get this login screen, which i'm assuming is the motorola cable modem. I tried any login combo's i could think of as well as most router defaults and I could not log in, I also did some reading online about it and people were saying there is nothing that can be changed in there anyways

jibs is offline   Reply With Quote
Old 02-10-2013, 12:38 PM   #17
AnonymouseUser
Diamond Member
 
AnonymouseUser's Avatar
 
Join Date: May 2003
Location: Dallas TX
Posts: 8,357
Default

The default IP address for the SB5102 is 192.168.100.1, so that is the modem and it is providing DHCP addresses.
__________________
NSA Homeland Security PRISM Denial of service Malware Trojan Keylogger Cyber Command
2600 Backpack Phishing Rootkit Agro Eco terrorism Conventional weapon
Target Weapons grade Dirty bomb Enriched Nuclear Chemical Biological weapon Black out
Pressure Cooker Grid Power Smart Body scanner Electric Failure Ammonium nitrate Brown Out
Bridge Organized crime National security State emergency Security Breach Threat Standoff
SWAT Screening Virus Environmental Terrorist Dock
AnonymouseUser is offline   Reply With Quote
Old 02-10-2013, 01:57 PM   #18
MontyAC
Diamond Member
 
MontyAC's Avatar
 
Join Date: Feb 2004
Posts: 4,044
Default

Try another router with your setup. Maybe your current router is defective.
MontyAC is offline   Reply With Quote
Old 02-10-2013, 02:06 PM   #19
JackMDS
Super Moderator
Elite Member
 
JackMDS's Avatar
 
Join Date: Oct 1999
Posts: 26,240
Default

Modem only device feeds out the public IP as assign by the ISP.

If the Modem feeds out private IP (like 192.168.x.x) then there is Routing circuits in the Modem and it is Modem/Router Combo.

Otherwise, look at the IP at the WAN port of your Router. If it is 192.168.xx.xx, then it gets a private IP and the Modem is a Modem Router.

Happened to me few times that the support of ISPs' call Modem/Router Modem and insist that it is a Modem and Not a Router.

My suspicion is that either they do not know, or they are instructed to call the thing Modem and Not to use any other name.

To find out the private IP and public IP of a functional computer this simple free app. can be used.

http://www.snapfiles.com/get/ip2.html (make sure that the Firewall is allowing it ).



__________________
Jack
Microsoft, MVP - Networking.

Last edited by JackMDS; 02-10-2013 at 02:09 PM.
JackMDS is offline   Reply With Quote
Old 02-10-2013, 04:11 PM   #20
jibs
Member
 
Join Date: Jul 2011
Location: Canada
Posts: 105
Default

I plugged my laptop directly into my cable modem and ran ipconfig /all, I was unable to access the internet, here are the results:

Windows IP Configuration
Host Name . . . . . . . . . . . . : Laptop
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
Physical Address. . . . . . . . . : XX-XX-XX-8B-34-50
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) 82567LM Gigabit Network Connecti
on
Physical Address. . . . . . . . . : XX-XX-XX-66-20-94
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::f1cf:2d6b:ffa5:2e0e%10(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.46.14(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 234891027
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-8A-6C-63-00-27-13-66-20-94

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{A9F7479C-662D-4D43-A5CC-CF34FE1FB6D2}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

I will try and find another router to connect, and look at resetting my current router to factory defaults to see if that help
jibs is offline   Reply With Quote
Old 02-10-2013, 04:39 PM   #21
owensdj
Golden Member
 
Join Date: Jul 2000
Posts: 1,600
Default

Jibs, many cable modems are set to only allow one network device to access the Internet through them at a time, either a computer plugged directly into the modem or a router. Once modem has allowed a router to connect through it it won't allow a computer to be directly connected until you cycle the power on the modem to clear the device's MAC address. That's why your laptop didn't work. Notice the 169.x.x.x address your laptop got. That means it was unable to find a DHCP server.

If you try another router you'll need to unplug the power to the modem before you try the new router.
__________________
Intel Core i7-3770 3.4GHz | Gigabyte GA-Z77MX-D3H | G.Skill 8GB (2x4GB) DDR3 1600 | Western Digital Caviar Black 1.5TB | Asus 24x DVD Burner | Hauppauge WinTV-HVR-2250 | PC Power & Cooling Silencer MK III 500W PSU | Cooler Master HAF 912 Case | Windows 7 Pro

Last edited by owensdj; 02-10-2013 at 08:56 PM.
owensdj is offline   Reply With Quote
Old 02-10-2013, 04:49 PM   #22
MontyAC
Diamond Member
 
MontyAC's Avatar
 
Join Date: Feb 2004
Posts: 4,044
Default

You can also try updating the wireless adapter driver in the laptop.
MontyAC is offline   Reply With Quote
Old 03-01-2013, 04:07 PM   #23
jibs
Member
 
Join Date: Jul 2011
Location: Canada
Posts: 105
Default

Alright so I've been screwing around with this problem on and off for the past few weeks and I can't seem to figure it out. I have tried 3 different wireless routers, flashed 1 of them to dd-wrt and I still can't get a proper IP address assigned without going the static route.

1 suggestion a friend made was to unplug the cable modem from the router, set your computer obtain an IP automatically and reboot to see what happens. I did this and my computers were all assigned IPs beginging with 192.168.100.xxx which is not what the router is set to assign.

I'm not sure what else I can try for this problem. Does anyone have any thoughts? I'm now using an Asus RT-AC66U router, which seems to provide more configuration options than my old E2000
jibs is offline   Reply With Quote
Old 03-01-2013, 04:35 PM   #24
AnonymouseUser
Diamond Member
 
AnonymouseUser's Avatar
 
Join Date: May 2003
Location: Dallas TX
Posts: 8,357
Default

One thing I would have done is to boot at least one wired computer with a Linux Live CD/DVD/USB to rule out a Windows configuration issue. If you get 192.168.100.x, reset the router and try again, to see if the router got the incorrect settings from the modem.
__________________
NSA Homeland Security PRISM Denial of service Malware Trojan Keylogger Cyber Command
2600 Backpack Phishing Rootkit Agro Eco terrorism Conventional weapon
Target Weapons grade Dirty bomb Enriched Nuclear Chemical Biological weapon Black out
Pressure Cooker Grid Power Smart Body scanner Electric Failure Ammonium nitrate Brown Out
Bridge Organized crime National security State emergency Security Breach Threat Standoff
SWAT Screening Virus Environmental Terrorist Dock
AnonymouseUser is offline   Reply With Quote
Old 03-01-2013, 05:41 PM   #25
jibs
Member
 
Join Date: Jul 2011
Location: Canada
Posts: 105
Default

I booted up my Linux Mint laptop and connected the it to the switch that is connected to my router, I received a 192.168.100.xxx IP address. I factory restored the wireless router, went through the initial config and the same thing happened. I just factory restored the router, did the config and connected the laptop and got a 192.168.100.xxx IP address.

If I assign a static IP to the laptop with a 192.168.1.xxx IP address everything works.
jibs is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.