Go Back   AnandTech Forums > Hardware and Technology > Networking

Forums
· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2014
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions
   

Reply
 
Thread Tools
Old 01-25-2013, 05:45 PM   #1
Nessism
Golden Member
 
Nessism's Avatar
 
Join Date: Dec 1999
Location: Torrance, CA
Posts: 1,601
Default Win 7 won't remember wireless network key

Used to remember but not any longer. Need to type the key every time I try to access the internet.

Box to remember password is checked.
Tried deleting the connection and entering new but that doesn't work either.

Any ideas?
__________________
"If at first you don't suck seed, suck again until you do suck seed (succeed)."
Curly Howard

HEAT
Nessism is offline   Reply With Quote
Old 01-25-2013, 07:48 PM   #2
Smoove910
Golden Member
 
Join Date: Aug 2006
Location: Nampa, Idaho
Posts: 1,094
Default

if you are on Windows 7, while you are connected, click the Network Bars in the lower right-hand corner of your screen:



A box will come up that shows all the available networks in your area... right click the one you are connected to and click on 'properties'.

Now click on the 'connections' tab, and ensure the 'connect automatically when this network is in range' box:

__________________
Mobo: Biostar TA880GU3+ uATX
Proc: AMD Phenom II 960T unlocked/6 cores @ 3.5ghz
Ram: (4) 4gb GSkill 1600mhz (16gb total)
HDDs: (2) 640GB WD AAKS, (1) 750GB Seagate Ext
Vid: Sapphire 6870 1gb DDR5 1000mhz core, 1100 mhz mem
Camera: Pentax K5, I'm not a Canikon fanboy.
Smoove910 is offline   Reply With Quote
Old 01-25-2013, 08:00 PM   #3
Nessism
Golden Member
 
Nessism's Avatar
 
Join Date: Dec 1999
Location: Torrance, CA
Posts: 1,601
Default

Thanks but already did this. Doesn't work.
__________________
"If at first you don't suck seed, suck again until you do suck seed (succeed)."
Curly Howard

HEAT
Nessism is offline   Reply With Quote
Old 01-25-2013, 08:26 PM   #4
nickbits
Diamond Member
 
nickbits's Avatar
 
Join Date: Mar 2008
Location: Southeast Michigan
Posts: 3,678
Default

Forget the network and reconnect. Could try changing ssid. Or reinstall windows.
nickbits is offline   Reply With Quote
Old 01-25-2013, 09:06 PM   #5
Smoove910
Golden Member
 
Join Date: Aug 2006
Location: Nampa, Idaho
Posts: 1,094
Default

alrighty, try this:

open search, type "services.msc" open services.
Scroll down to "wlan auto config" right click, stop the service.

Navigate to
"C: \ProgramData\Microsoft\Wlansvc\ delete everything in this folder leaving only a folder called "profiles" delete everything in the "profiles" folder except for a folder called "interfaces" delete everything in the "interfaces" folder)

Restart "wlan auto config" connect to your wireless network, enter
your passkey, (ensure the connect automaticly box is checked)

Restart your computer job done, your computer will now connect to your wireless network automaticly on boot.
__________________
Mobo: Biostar TA880GU3+ uATX
Proc: AMD Phenom II 960T unlocked/6 cores @ 3.5ghz
Ram: (4) 4gb GSkill 1600mhz (16gb total)
HDDs: (2) 640GB WD AAKS, (1) 750GB Seagate Ext
Vid: Sapphire 6870 1gb DDR5 1000mhz core, 1100 mhz mem
Camera: Pentax K5, I'm not a Canikon fanboy.
Smoove910 is offline   Reply With Quote
Old 01-25-2013, 10:24 PM   #6
Nessism
Golden Member
 
Nessism's Avatar
 
Join Date: Dec 1999
Location: Torrance, CA
Posts: 1,601
Default

Quote:
Originally Posted by Smoove910 View Post
alrighty, try this:

open search, type "services.msc" open services.
Scroll down to "wlan auto config" right click, stop the service.

Navigate to
"C: \ProgramData\Microsoft\Wlansvc\ delete everything in this folder leaving only a folder called "profiles" delete everything in the "profiles" folder except for a folder called "interfaces" delete everything in the "interfaces" folder)

Restart "wlan auto config" connect to your wireless network, enter
your passkey, (ensure the connect automaticly box is checked)

Restart your computer job done, your computer will now connect to your wireless network automaticly on boot.

Don't have a folder called "ProgramData".

Hidden?

Not sure what to do.
__________________
"If at first you don't suck seed, suck again until you do suck seed (succeed)."
Curly Howard

HEAT

Last edited by Nessism; 01-25-2013 at 10:27 PM.
Nessism is offline   Reply With Quote
Old 01-25-2013, 10:29 PM   #7
Smoove910
Golden Member
 
Join Date: Aug 2006
Location: Nampa, Idaho
Posts: 1,094
Default

yup, it's hidden

Open Folder Options by clicking the Start button , clicking Control Panel, clicking Appearance and Personalization, and then clicking Folder Options.

Click the View tab.

Under Advanced settings, click Show hidden files and folders, and then click OK.
__________________
Mobo: Biostar TA880GU3+ uATX
Proc: AMD Phenom II 960T unlocked/6 cores @ 3.5ghz
Ram: (4) 4gb GSkill 1600mhz (16gb total)
HDDs: (2) 640GB WD AAKS, (1) 750GB Seagate Ext
Vid: Sapphire 6870 1gb DDR5 1000mhz core, 1100 mhz mem
Camera: Pentax K5, I'm not a Canikon fanboy.
Smoove910 is offline   Reply With Quote
Old 01-25-2013, 10:44 PM   #8
Nessism
Golden Member
 
Nessism's Avatar
 
Join Date: Dec 1999
Location: Torrance, CA
Posts: 1,601
Default

Okay, found it.

Followed your instructions and it didn't work.

Shut down "wlan auto config"

Deleted all the stuff in the "interfaces" folder. The profiles folder didn't have anything in it other than the interfaces folder.

Restarted "wlan auto config".

Rebooted, typed password to get on the internet to confirm it worked.

Rebooted again and system didn't remember password.

Thanks so much for the help so far. Back where I started though I'm afraid.
__________________
"If at first you don't suck seed, suck again until you do suck seed (succeed)."
Curly Howard

HEAT
Nessism is offline   Reply With Quote
Old 01-25-2013, 10:49 PM   #9
Smoove910
Golden Member
 
Join Date: Aug 2006
Location: Nampa, Idaho
Posts: 1,094
Default

hmmm, strange. You can go through the search I did on google and try other suggestions. Sorry it didn't work for you:

https://www.google.com/search?q=wind...hrome&ie=UTF-8
__________________
Mobo: Biostar TA880GU3+ uATX
Proc: AMD Phenom II 960T unlocked/6 cores @ 3.5ghz
Ram: (4) 4gb GSkill 1600mhz (16gb total)
HDDs: (2) 640GB WD AAKS, (1) 750GB Seagate Ext
Vid: Sapphire 6870 1gb DDR5 1000mhz core, 1100 mhz mem
Camera: Pentax K5, I'm not a Canikon fanboy.
Smoove910 is offline   Reply With Quote
Old 01-25-2013, 11:12 PM   #10
JackMDS
Super Moderator
Elite Member
 
JackMDS's Avatar
 
Join Date: Oct 1999
Posts: 26,346
Default

Look at the Wireless Manger Right click on a connection there is menu concerning the Users that if checked incorrectly it might cause the issue.


__________________
Jack
Microsoft, MVP - Networking.

Last edited by JackMDS; 01-26-2013 at 10:30 AM.
JackMDS is offline   Reply With Quote
Old 01-25-2013, 11:41 PM   #11
Nessism
Golden Member
 
Nessism's Avatar
 
Join Date: Dec 1999
Location: Torrance, CA
Posts: 1,601
Default

Think I got it.

Went though Smoove910's instructions again, AND uninstalled the wireless adapter's software. Rebooted and this time only installed the adapters driver, not the other software junk. I think there was a software conflict because now the system remembers the password.

Thanks for the help.
__________________
"If at first you don't suck seed, suck again until you do suck seed (succeed)."
Curly Howard

HEAT
Nessism is offline   Reply With Quote
Old 05-12-2013, 12:00 PM   #12
Tristram
Junior Member
 
Join Date: May 2013
Location: Maine
Posts: 1
Default

Thank you Smoove910 for your advice on wiping out everything in the Interfaces folder, then trying again. I was having exactly the same problem, having to key in the wifi password each time. I did as you described, then rebooted and it fixed my problem. Nice work!
Tristram is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.