Go Back   AnandTech Forums > Hardware and Technology > Motherboards

Forums
· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2014
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions
   

Reply
 
Thread Tools
Old 12-13-2012, 06:31 AM   #1
Dethoff
Member
 
Join Date: Jul 2000
Posts: 68
Default Asrock H61M/U3s3 driver missing

I just built a computer with the H61M/U3s3 MB and an Intel Core i3-3220 Ivy Bridge processor.

The board arrived with a recent BIOS (needed to support the ivy bridge family.)

The install went fine and all seems well, except one thing bugs me..


In device manager, there is an unknown device which has no driver loaded. It is listed as:

"Intel H61 express chipset family LPC interface controller"

I had loaded all the drivers from the motherboard driver disc, and even ran the system through Intel's Driver update utility.

By searching the web, I did find some sites (non Intel's) which list a driver for this, but don't understand why it would not have been installed with my MB disk. I was reluctant to download it from a non trusted site.

What gives?
Is it of any concern?

Thanks

Thanks,
Dethoff is offline   Reply With Quote
Old 12-13-2012, 12:27 PM   #2
tracerbullet
Golden Member
 
tracerbullet's Avatar
 
Join Date: Feb 2001
Location: St. Paul, MN
Posts: 1,278
Default

You've probably thought of / tried but just in case, anything here: http://www.intel.com/content/www/us/...chipset+driver ?

Windows may have an "optional update" for it?
__________________
ebay / Heat
tracerbullet is offline   Reply With Quote
Old 12-13-2012, 02:20 PM   #3
pauldun170
Platinum Member
 
pauldun170's Avatar
 
Join Date: Sep 2011
Posts: 2,103
Default

I always chuck the disc that came in the box and load the latest drivers from the manufacturers website\intel website\add-on website.

http://www.asrock.com/mb/overview.as...odel=H61M/U3S3
pauldun170 is offline   Reply With Quote
Old 12-13-2012, 02:37 PM   #4
pauldun170
Platinum Member
 
pauldun170's Avatar
 
Join Date: Sep 2011
Posts: 2,103
Default

Install install the CIR receiver driver ver:20091016 from the Asrock site and report back
pauldun170 is offline   Reply With Quote
Old 12-13-2012, 05:04 PM   #5
Dethoff
Member
 
Join Date: Jul 2000
Posts: 68
Default problem solved

I went to the Intel driver download page and downloaded the Intel® Chipset Device Software (INF Update Utility) found here:

http://downloadcenter.intel.com/Deta...&DownloadType=

This fixed the problem.

THX
Dethoff is offline   Reply With Quote
Reply

Tags
asrock h61m/u3s3, lpc interface controller

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.