Go Back   AnandTech Forums > Hardware and Technology > Motherboards

Forums
· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2014
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions
   

View Poll Results: Have you experienced bent pins or dead memory sockets/channels on this board?
Yes 0 0%
No 4 100.00%
Voters: 4. You may not vote on this poll

Reply
 
Thread Tools
Old 12-04-2012, 08:22 PM   #1
Handsome Rob
Junior Member
 
Join Date: May 2011
Posts: 8
Default ASUS P8Z77-V LK Owners: Bent socket pins

Just out of curiosity.

On Newegg of 239 customer reviews:
64 negative. 26.78%
31 specifically on bent socket pins or a dead memory channel due to bent pins. 12.98%

Search the forums and find even more.

Did you get burned? Do you own this board satisfied? Wondering how bad the QC really is.

Think I'm going to make an Office Space copier video rather than waste any more of my life on hold to ASUS, they've taken enough and I know they won't do anything.
Handsome Rob is offline   Reply With Quote
Old 12-04-2012, 10:42 PM   #2
bankster55
Golden Member
 
bankster55's Avatar
 
Join Date: Mar 2010
Posts: 1,124
Default

Did you have bent pins?
Did you find out before or after setting up PC?
Is it possible to take a good res pic?
__________________
I actually have ~8000 AT posts, was in first group to join Sep. 99 (text only format) - just too lazy to import my info. In fact, its kinda nice to be anonymous. Remember those live meet and greet other local AT members OT threads?

bankster55 is offline   Reply With Quote
Old 12-04-2012, 11:48 PM   #3
GPz1100
Senior Member
 
Join Date: Jun 2001
Posts: 337
Default

My first p8z77v deluxe had crooked resistors near the cpu socket. Pins in the socket appeared fine. I didn't bother installing the board as I was bothered by a $250+ board having crooked components. Exchanged for another which was fine.

Recently bought another p8z77v lk to use in a build. No crooked pins.

I take the reviews on newegg with salt. You read many reports of memory issues or error 55. I think much of the issue is that folks try to run the memory at overclocked settings (>1600mhz) with bios that doesn't support it very well. I ran into this issue myself on the deluxe board with 1866 ram. Even with all manual settings, it still wouldn't POST. Seemed like whatever manual settings I was setting were being overridden by something. The most current bios corrected this (11/xx/2012 release for the deluxe board).
__________________
Living reality in a dream

p8z77v-deluxe, 3770K @ 4.6, +.050V offset, LLC at high, xspc raystorm/ex360 WC
GPz1100 is offline   Reply With Quote
Old 12-05-2012, 06:44 AM   #4
Handsome Rob
Junior Member
 
Join Date: May 2011
Posts: 8
Default

I found out after, trying to troubleshoot the A memory channel.. You need good light and just the right angle to see it. 1 pin bent 90 left, 1 pin bent 90 right, 1.5 cm apart with no damage anywhere else. How that can happen from closing the socket is beyond me.

Correspond it with a 25% RMA rate and 13% specifically on bent socket pins, and something smells awfully fishy. I'd expect complaints at a 10% rate to be the norm, with half of them user error but 25% is just ridiculous. GPz1100 you don't get 1 dead and 1 functioning memory channel from overclocked memory, and just trying to get it to post it defaults to 1333 anyway.

I wouldn't be angry if I didn't waste 1/4 of a day trying to get through to ASUS to find out what the service repair rates are, more than the retail cost of the board. That might be the worst customer service I've ever experienced in my entire life, anywhere.
Handsome Rob is offline   Reply With Quote
Old 12-05-2012, 02:10 PM   #5
bankster55
Golden Member
 
bankster55's Avatar
 
Join Date: Mar 2010
Posts: 1,124
Default

It used to happen regularly with Z68 and P67
Guys would allow the pin protector to touch the pins when removing it..
The pins are incredibly fragile and if you just barely touch them they bend
The problem was that the pin protector sat UNDER the locking plate on top of the grid.
Asus tried to fix this by putting the pin protector on top of the locking plate, starting with Z77
One may open the plate and put in a CPU with pin protector still in, and then close the lock plate onto the CPU and the protector pops out
Or one may open the lock plate and pop the protector out of the lock plate with a finger.
This should have fixed things but it hasnt.
Endusers can still drop the CPU at an angle into the grid.
Then theres aways the stray finger touch
Also if the CPU is not perfectly seated while using the top plate to pop the protector, it will move the CPU slightly foward because the pin protector hits the CPU at top edge first and the bottom edge of CPU will flop up and down

As far as QC, ASUS no longer uses Pegatron as their manuf of mobo as of 2 months ago. So it would be nice to know what month your mobo was manuf if possible.

If not mangled, the pins can be straightened. I use a lighted eye magnifier and two large sewing needles.
__________________
I actually have ~8000 AT posts, was in first group to join Sep. 99 (text only format) - just too lazy to import my info. In fact, its kinda nice to be anonymous. Remember those live meet and greet other local AT members OT threads?

bankster55 is offline   Reply With Quote
Old 12-05-2012, 03:03 PM   #6
Handsome Rob
Junior Member
 
Join Date: May 2011
Posts: 8
Default

I still don't buy it.

This is my 13th build. 478, LGA775, AM3, AM3+, LGA1156, LGA1155....never had an issue.

Bought an MSI board and went in no problem.

This is the one and only board, and there are dozens of other reports with the exact same complaint like I've never seen before, Occam's razor suggests...

I'll check the date on the board, don't have it with me but its got FoxConn branding all over it. Incredibly cheap manufacture with 6 screws instead of 9 you feel like you're going to bend it putting in the RAM. Had to put it in outside the case and then mount the motherboard after.

The one certainty is the ASUS will never see another penny. The only thing worse than the quality control is the customer service.
Handsome Rob is offline   Reply With Quote
Old 12-05-2012, 07:46 PM   #7
makken
Golden Member
 
Join Date: Aug 2004
Posts: 1,465
Default

Brought this mobo 2 months ago. No issue with bent pins, but mine had dead SATA ports. RMA was a pain.
makken is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.