Go Back   AnandTech Forums > Hardware and Technology > Motherboards

Forums
· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Home and Garden
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2014
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions
   

Reply
 
Thread Tools
Old 11-05-2012, 11:06 AM   #1
spdfreak
Senior Member
 
Join Date: Mar 2000
Posts: 575
Default USB 3.0 drivers for ASUS F2A85-M

This is one of the new FM2 boards and Win7 doesn't have the USB3 drivers for it. They also are not on the ASUS driver disc or site unless they are hidden or labeled as something else. In the utilities section there is a thing called USB3.0 boost in the AI Suite. Anyone have any experience with one of these boards?
__________________
“Criticize through creating.” Michelangelo
spdfreak is offline   Reply With Quote
Old 11-05-2012, 03:49 PM   #2
cl-scott
ASUS Support
 
Join Date: Jul 2012
Posts: 457
Default

From what I am seeing, they should be part of the chipset driver package. If that doesn't end up being the case, let me know and I'll pester one of the components people about it. I always enjoy a good reason to bother one of them in particular.
__________________
Scott Billings
Asus Customer Loyalty
Email: cl-scott@asus.com

Opinions expressed are not necessarily those of Asus or Anandtech
cl-scott is offline   Reply With Quote
Old 11-07-2012, 04:54 PM   #3
spdfreak
Senior Member
 
Join Date: Mar 2000
Posts: 575
Default

It is apparently the 3rd party USB chip- I think ASMedia. The AMD drivers load OK but device manager still sees a USB bus without drivers and the 2 blue ports on the back don't work. I tried using the USB 3.0 boost drivers on the disc and they try to load but windows always says that it was unsuccessful. Windows update does not have anything for that chip either.
__________________
“Criticize through creating.” Michelangelo
spdfreak is offline   Reply With Quote
Old 11-07-2012, 09:47 PM   #4
krose
Senior Member
 
krose's Avatar
 
Join Date: Aug 2004
Location: South Central PA
Posts: 388
Default

If it is Asmedia, perhaps you can find the proper drivers here.

Last edited by krose; 11-07-2012 at 09:54 PM.
krose is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.