Go Back   AnandTech Forums > Software > Software for Windows

Forums
· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2014
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions
   

Reply
 
Thread Tools
Old 11-04-2012, 04:47 PM   #1
Compman55
Senior Member
 
Join Date: Feb 2010
Posts: 985
Default Which browser for flash videos. Firefox/Chrome/Safari

Firefox seems to get unresponsive after a day of having some youtube videos open. When I had 2GB of ram it was unusable. With 8GB after about 2 days the scripts start to hang.

So do I ditch firefox for somthing else?
__________________
-Main: Fractal Arc Midi R2 | Z87-Pro | E3-1245V3 | 32GB | M500 240GB | Antec HCG-620m PSU | Win7x64 Pro | Dual Dell U2414H Borderless IPS Panels w/ MDS14 stand |
-HTPC: Mac mini | P7550 2.26 | 8GB | 500GB 7K500 | OS X 10.6.8 | Win7x64 Ultimate |
-Lappy: Dell Latitude D820 | C2D 2.0 | 2GB | 128GB Samsung 830 SSD | 15.4" WXGA | Win7 x86 Ultimate |
-Server: G2020 | 8GB | 500GB WD Black (OS)| 2x Seagate 4TB | 2x Segate 2TB |
Compman55 is offline   Reply With Quote
Old 11-04-2012, 04:59 PM   #2
lxskllr
Lifer
 
lxskllr's Avatar
 
Join Date: Nov 2004
Location: Somewhere over the rainbow
Posts: 38,362
Default

Could be the cache filling up. Try clearing it.

I've had issues with Chromium, where it's been using up all my ram(8gb). I haven't bothered tracking the problem down because it's a secondary browser for me. I /think/ it might be Flash related, but don't know for sure.
lxskllr is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.