Go Back   AnandTech Forums > Consumer Electronics > Audio/Video & Home Theater

Forums
· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Home and Garden
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2014
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions
   

Reply
 
Thread Tools
Old 09-27-2012, 06:02 AM   #1
Jurge92
Member
 
Jurge92's Avatar
 
Join Date: Aug 2012
Location: Norway
Posts: 55
Default EasyCap DC60++ recognized as usbtv007

Hi.

I've been searching the Internet for days and spent countless of hours on trying to figure out why my EasyCap DC60++ wont work. I've tried drivers that work for some, and other drivers, and more drivers, but nothing seems to work! It's recognized under devices as usbtv007. I've been using the software that came along with the EasyCap, some Honestech shit, and latest Ulead VideoStudio 10, but none of them seems to find the device. Does anyone know what I can do? I'm about to give up and just give my 8mm DV's to a company who do this for money. I hope it wont get to that, cause it's crazy expensive. So please, help.

And FYI I'm running Windows 7 64-bit.
Jurge92 is offline   Reply With Quote
Old 04-03-2013, 02:51 PM   #2
Fetlabeta
Junior Member
 
Join Date: Apr 2013
Posts: 1
Default EasyCap DC60++ recognized as usbtv007 (FIX!!!)

Its easy to fix for people who have this problem.I experienced it myself.And it is pretty easy to fix.This problem may occur if you have tried to update the drivers from somewhere else rather than the disk.If you are reading this post please do not update the driver on the EasyCAP usbtv007 (OEM DEVICE) as it will destroy the EasyCAP drivers and make your computer not recognize it.Solution number 1 is to do a system restore (Search programs and files > Type in System restore),restore it back to a time where you never updated the files on your EasyCAP. If you can't do that, restore your PC back to its factory settings so your PC will be fresh new.If your not willing to do that, use another PC which has a windows vista or 7 operating system.Install the drivers via EasyCAP disk (Yellow disk).Once you installed all the drivers plug in your EasyCAPand start recording with the software you use.

If you have anymore questions please post a comment on my website: http://www.fetlabeta.com
Fetlabeta is offline   Reply With Quote
Reply

Tags
dc60++, easycap, usbtv007

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.