Go Back   AnandTech Forums > Forum Issues > Technical Forum Issues

Forums
· Hardware and Technology
· CPUs and Overclocking
· Motherboards
· Video Cards and Graphics
· Memory and Storage
· Power Supplies
· Cases & Cooling
· SFF, Notebooks, Pre-Built/Barebones PCs
· Networking
· Peripherals
· General Hardware
· Highly Technical
· Computer Help
· Home Theater PCs
· Consumer Electronics
· Digital and Video Cameras
· Mobile Devices & Gadgets
· Audio/Video & Home Theater
· Software
· Software for Windows
· All Things Apple
· *nix Software
· Operating Systems
· Programming
· PC Gaming
· Console Gaming
· Distributed Computing
· Security
· Social
· Off Topic
· Politics and News
· Discussion Club
· Love and Relationships
· The Garage
· Health and Fitness
· Merchandise and Shopping
· For Sale/Trade
· Hot Deals with Free Stuff/Contests
· Black Friday 2014
· Forum Issues
· Technical Forum Issues
· Personal Forum Issues
· Suggestion Box
· Moderator Resources
· Moderator Discussions
   

Reply
 
Thread Tools
Old 02-20-2011, 09:22 AM   #1
Perknose
Forum Director &
Omnipotent Overlord
 
Perknose's Avatar
 
Join Date: Oct 1999
Posts: 36,537
Default Problems With Dynamite Data?

Post 'em here!
__________________
The first duty of love is to listen.

-- Paul Tillich

To truly listen is to risk being changed forever.

-- Sa' k' ej Henderson
Perknose is offline   Reply With Quote
Old 02-20-2011, 10:19 AM   #2
shortylickens
No Lifer
 
shortylickens's Avatar
 
Join Date: Jul 2003
Posts: 55,024
Default

Any time I link to Amazon, Newegg, or IMDB. It hiccups whenever I click on the link to check it. Sometimes the page never comes up. Ditto other peoples links. Never happens with youtube, but I dont know when you guys use Dynamite or not. I never see the refer link in the lower left corner, but it could be going so fast I cant see it.

I dont know if it matters but I'm using Chrome 9 with adblock and Java block. However I do not have ads or Java blocked on this site or any of the above sites.
__________________
2 Timothy 4:7
shortylickens is offline   Reply With Quote
Old 02-20-2011, 11:08 AM   #3
Skurge
Diamond Member
 
Skurge's Avatar
 
Join Date: Aug 2009
Location: Namibia
Posts: 4,941
Default

Yeah, when linking to newegg, It takes me to a completely different section from the one I linked. Its only on rare occasions though.
__________________
Intel Core i5-4670K |MSI Z97-Gaming 5|32GB DDR3-1600|Gigabyte R9 290 Windforce CF [stock]|Samsung SSD 840 Evo 500GB|Corsair AX860 PSU|Corsair 750D|Windows 8.1 Pro|Samsung U28D590D|Logitech G27 Racing Wheel|Nexus 5 32GB
Skurge is offline   Reply With Quote
Old 02-20-2011, 11:54 AM   #4
DynamiteMatt
Member
 
Join Date: Jun 2010
Posts: 45
Default

Quote:
Originally Posted by shortylickens View Post
Any time I link to Amazon, Newegg, or IMDB. It hiccups whenever I click on the link to check it. Sometimes the page never comes up. Ditto other peoples links. Never happens with youtube, but I dont know when you guys use Dynamite or not. I never see the refer link in the lower left corner, but it could be going so fast I cant see it.

I dont know if it matters but I'm using Chrome 9 with adblock and Java block. However I do not have ads or Java blocked on this site or any of the above sites.
Hi shortylickens,

We have been working hard to improve the speed and stability of our redirector. Because of the affiliate process, a user may be passed through multiple servers beyond our own before reaching the intended product page. There is little we can do to speed this process up. Even so, the time it takes should be minimal (under a few seconds).

Newegg will probably generally have a longer affiliation time. Amazon should be one of the fastest. IMDB links should not be passing through our servers at all, and any delay you are experiencing is purely the result of their website.

Please let us know if you are able to find any specific cases of problems where the page never loads and we will look into it immediately.

Thanks,

Matt
Dynamite Data
DynamiteMatt is offline   Reply With Quote
Old 02-20-2011, 11:56 AM   #5
DynamiteMatt
Member
 
Join Date: Jun 2010
Posts: 45
Default

Quote:
Originally Posted by Skurge View Post
Yeah, when linking to newegg, It takes me to a completely different section from the one I linked. Its only on rare occasions though.
Hi Skurge,

That behavior should definitely not be happening. If you run into any specific examples again, please post or message me and I can look into it immediately.

Thanks,

Matt
Dynamite Data
DynamiteMatt is offline   Reply With Quote
Old 02-20-2011, 01:35 PM   #6
Numenorean
Diamond Member
 
Numenorean's Avatar
 
Join Date: Oct 2008
Location: Númenor
Posts: 4,442
Default

1: It sucks.

2: It often takes 2 minutes just to bring up a link, if not longer, if it ever does bring up a link at all. So I used URL shorteners to prevent this issue. But since you've been blocking URL shorteners so that people have to use this dynamite data crap I've just been posting product ID's that people can paste into NewEgg, etc. so they don't have to bother with this crap.

3: Basically I frown upon anything that distorts a link I post into something else. It's like I'm spamming the forums when that happens, and nobody likes spammers.
Numenorean is offline   Reply With Quote
Old 02-20-2011, 01:46 PM   #7
Skurge
Diamond Member
 
Skurge's Avatar
 
Join Date: Aug 2009
Location: Namibia
Posts: 4,941
Default

It doesn't seem to be happening anymore, usually when I would link to a search result it would take me to a different section. Like if would link to the hardware section and the link would take people to the Windows 7 section for example.

I'll post it here if its happens again.
__________________
Intel Core i5-4670K |MSI Z97-Gaming 5|32GB DDR3-1600|Gigabyte R9 290 Windforce CF [stock]|Samsung SSD 840 Evo 500GB|Corsair AX860 PSU|Corsair 750D|Windows 8.1 Pro|Samsung U28D590D|Logitech G27 Racing Wheel|Nexus 5 32GB
Skurge is offline   Reply With Quote
Old 02-20-2011, 04:04 PM   #8
shortylickens
No Lifer
 
shortylickens's Avatar
 
Join Date: Jul 2003
Posts: 55,024
Default

TEST

http://www.newegg.com/Product/Produc...00B8-_-Product

http://www.amazon.com/White-Gold-28-...8239459&sr=1-1
__________________
2 Timothy 4:7
shortylickens is offline   Reply With Quote
Old 02-20-2011, 06:08 PM   #9
Anubis
No Lifer
 
Anubis's Avatar
 
Join Date: Aug 2001
Location: Anger is a gift!
Posts: 74,363
Default

the prob with it is that we use it at all, just flat out remove it and we wont have anymore issues
Anubis is online now   Reply With Quote
Old 02-20-2011, 06:40 PM   #10
Tsavo
Platinum Member
 
Tsavo's Avatar
 
Join Date: Sep 2009
Posts: 2,316
Default

Horrible garbage. 100% no worky.
__________________
i5-3570K, i5-750. i5-2410M. i3-2100/2120.
Tsavo is offline   Reply With Quote
Old 02-20-2011, 08:28 PM   #11
shortylickens
No Lifer
 
shortylickens's Avatar
 
Join Date: Jul 2003
Posts: 55,024
Default

Quote:
Originally Posted by Anubis View Post
the prob with it is that we use it at all, just flat out remove it and we wont have anymore issues
Thats fine but can you guarantee everyone here will stop using adblock, cuz anandtech needs money one way or another.
__________________
2 Timothy 4:7
shortylickens is offline   Reply With Quote
Old 02-21-2011, 02:33 AM   #12
Soundmanred
Lifer
 
Join Date: Oct 2006
Location: Czelktik, Uzbenistaz
Posts: 10,669
Default

I can't count the times this crap doesn't work right, or work at all.
Now I just read the post and then go to whatever website is linked and look for the item (or whatever) instead of clicking the link.
At least that way I know where I'm going.
There have to be better options.
I do agree with a quote from their website - "Our technology is revolutionary and disruptive."
Sadly, I agree with the latter.

Last edited by Soundmanred; 02-21-2011 at 02:35 AM.
Soundmanred is online now   Reply With Quote
Old 02-21-2011, 02:39 AM   #13
Mike Gayner
Diamond Member
 
Mike Gayner's Avatar
 
Join Date: Jan 2007
Posts: 6,179
Default

DD links work maybe 25% of the time for me. Most of the time they redirect to a completely unrelated page from a completely unrelated vendor.
Mike Gayner is offline   Reply With Quote
Old 02-21-2011, 09:25 AM   #14
Anubis
No Lifer
 
Anubis's Avatar
 
Join Date: Aug 2001
Location: Anger is a gift!
Posts: 74,363
Default

Quote:
Originally Posted by shortylickens View Post
Thats fine but can you guarantee everyone here will stop using adblock, cuz anandtech needs money one way or another.
TBH i think most people would not have issues with adds is they were simply text adds. however big flashy flash graphic adds piss people off so they get blocked
Anubis is online now   Reply With Quote
Old 02-21-2011, 12:16 PM   #15
DynamiteMatt
Member
 
Join Date: Jun 2010
Posts: 45
Default

Quote:
Originally Posted by Numenorean View Post
1: It sucks.

2: It often takes 2 minutes just to bring up a link, if not longer, if it ever does bring up a link at all. So I used URL shorteners to prevent this issue. But since you've been blocking URL shorteners so that people have to use this dynamite data crap I've just been posting product ID's that people can paste into NewEgg, etc. so they don't have to bother with this crap.

3: Basically I frown upon anything that distorts a link I post into something else. It's like I'm spamming the forums when that happens, and nobody likes spammers.
Hi Numenorean,

There was a time at which the redirector was very slow, but we have made significant architectural and code level improvements over the last few weeks, and it should no longer be exhibiting issues.

The redirector is necessary to financially support Anandtech. Many other forums use similar technology. The technology is only applied to merchant urls. The best we can do is address any specific redirect problems you may be having with it.

If you could cite any current cases where the redirect takes an abnormally high length of time, I would be happy to look into it.

Thanks,

Matt
Dynamite Data
DynamiteMatt is offline   Reply With Quote
Old 02-21-2011, 12:16 PM   #16
DynamiteMatt
Member
 
Join Date: Jun 2010
Posts: 45
Default

Quote:
Originally Posted by Skurge View Post
It doesn't seem to be happening anymore, usually when I would link to a search result it would take me to a different section. Like if would link to the hardware section and the link would take people to the Windows 7 section for example.

I'll post it here if its happens again.
Hi Skurge,

Thanks, we appreciate any time spent to detail an issue.

Matt
Dynamite Data
DynamiteMatt is offline   Reply With Quote
Old 02-21-2011, 12:16 PM   #17
DynamiteMatt
Member
 
Join Date: Jun 2010
Posts: 45
Default

Quote:
Originally Posted by Anubis View Post
the prob with it is that we use it at all, just flat out remove it and we wont have anymore issues
Hi Anubis,

The redirector is necessary to financially support Anandtech. It also deters spammers from posting links, since the technology removes their tags.

We believe we have corrected most of the speed and stability issues, but please let us know if you have any current problems.

Thanks,

Matt
Dynamite Data
DynamiteMatt is offline   Reply With Quote
Old 02-21-2011, 12:17 PM   #18
DynamiteMatt
Member
 
Join Date: Jun 2010
Posts: 45
Default

Quote:
Originally Posted by Soundmanred View Post
I can't count the times this crap doesn't work right, or work at all.
Now I just read the post and then go to whatever website is linked and look for the item (or whatever) instead of clicking the link.
At least that way I know where I'm going.
There have to be better options.
I do agree with a quote from their website - "Our technology is revolutionary and disruptive."
Sadly, I agree with the latter.
Hi Soundmanred,

We'd like you to give us another chance. There were some speed and stability issues in the past, but we believe we have corrected most if not all of them.

Ultimately, the redirector is necessary to support AnandTech. Any time spent reporting a specific issue would be immensely appreciated, and I would look into it right away.

Thanks,

Matt
Dynamite Data
DynamiteMatt is offline   Reply With Quote
Old 02-21-2011, 12:18 PM   #19
DynamiteMatt
Member
 
Join Date: Jun 2010
Posts: 45
Default

Quote:
Originally Posted by Mike Gayner View Post
DD links work maybe 25% of the time for me. Most of the time they redirect to a completely unrelated page from a completely unrelated vendor.
Hi Mike Gayner,

We manually check the links in the Hot Deals forum daily. I have not been able to reproduce this behavior. You may want to check that you do not have anything else installed that may be disrupting your browsing.

If you could provide a specific example of this happening, I would be happy to look into it.

Thanks,

Matt
Dynamite Data
DynamiteMatt is offline   Reply With Quote
Old 02-21-2011, 01:59 PM   #20
Numenorean
Diamond Member
 
Numenorean's Avatar
 
Join Date: Oct 2008
Location: Númenor
Posts: 4,442
Default

Quote:
Originally Posted by DynamiteMatt View Post
Hi Numenorean,

There was a time at which the redirector was very slow, but we have made significant architectural and code level improvements over the last few weeks, and it should no longer be exhibiting issues.

The redirector is necessary to financially support Anandtech. Many other forums use similar technology. The technology is only applied to merchant urls. The best we can do is address any specific redirect problems you may be having with it.

If you could cite any current cases where the redirect takes an abnormally high length of time, I would be happy to look into it.

Thanks,

Matt
Dynamite Data
Pretty much any time that I have actually clicked on it it takes forever.

I have stopped clicking on redirect links and if I need to follow it I use the ID of the product in the link.

If the only way to survive financially is by surreptitiously replacing links in posts to some other company, then you need to rethink what you're doing.
Numenorean is offline   Reply With Quote
Old 02-21-2011, 02:05 PM   #21
Numenorean
Diamond Member
 
Numenorean's Avatar
 
Join Date: Oct 2008
Location: Númenor
Posts: 4,442
Default

Quote:
Originally Posted by DynamiteMatt View Post
Hi Mike Gayner,

We manually check the links in the Hot Deals forum daily. I have not been able to reproduce this behavior. You may want to check that you do not have anything else installed that may be disrupting your browsing.

If you could provide a specific example of this happening, I would be happy to look into it.

Thanks,

Matt
Dynamite Data
You're just checking one forum?

Linking to NewEgg and other sites is very common in the General Hardware and Computer Help forums where help is provided in recommendations to others for computer upgrades and such. That's where I have run into the problems with a link saying NewEgg and going to CNet's Shopper.com or whatever their crappy site is.

I posted about it, but by the time someone else looked at it it was "fixed" somehow.

Anyway, I will continue not using the redirect to point out products since I prefer for my links to go where I link to and not somewhere else.
Numenorean is offline   Reply With Quote
Old 02-21-2011, 02:20 PM   #22
Soundmanred
Lifer
 
Join Date: Oct 2006
Location: Czelktik, Uzbenistaz
Posts: 10,669
Default

Quote:
Originally Posted by DynamiteMatt View Post
Hi Soundmanred,

We'd like you to give us another chance. There were some speed and stability issues in the past, but we believe we have corrected most if not all of them.

Ultimately, the redirector is necessary to support AnandTech. Any time spent reporting a specific issue would be immensely appreciated, and I would look into it right away.

Thanks,

Matt
Dynamite Data
I'll be honest and say that while I support the forums, I'd rather pay a subscription fee than beta test your software. It doesn't matter to me why it doesn't work, only that it doesn't work.
As far as I can tell, it's still slow and still doesn't connect to where it's supposed to (or at all) half the time and that's unacceptable.
I would love nothing more than the software to work, but it's obvious to me and many other members that it simply isn't the case.
Soundmanred is online now   Reply With Quote
Old 02-21-2011, 02:26 PM   #23
Numenorean
Diamond Member
 
Numenorean's Avatar
 
Join Date: Oct 2008
Location: Númenor
Posts: 4,442
Default

I don't care if their software works, I'd rather they just get rid of it anyway.
Numenorean is offline   Reply With Quote
Old 02-21-2011, 08:00 PM   #24
Motorheader
Diamond Member
 
Motorheader's Avatar
 
Join Date: Sep 2000
Location: Lemmy's Tour Bus
Posts: 3,682
Default

http://www.tkqlhce.com/click-3332167...82E16820233107

Link just died 3 times when clicking on a link in FS/FT. Had nothing to do with the link I was trying to goto.
__________________
My Heatware

Who is dis doin' this synthetic type of alpha beta psychedelic funkin'?
Motorheader is offline   Reply With Quote
Old 02-21-2011, 09:59 PM   #25
mnewsham
Lifer
 
mnewsham's Avatar
 
Join Date: Oct 2010
Location: Under the covers
Posts: 11,575
Default

Quote:
Originally Posted by Numenorean View Post
You're just checking one forum?

Linking to NewEgg and other sites is very common in the General Hardware and Computer Help forums where help is provided in recommendations to others for computer upgrades and such. That's where I have run into the problems with a link saying NewEgg and going to CNet's Shopper.com or whatever their crappy site is.

I posted about it, but by the time someone else looked at it it was "fixed" somehow.

Anyway, I will continue not using the redirect to point out products since I prefer for my links to go where I link to and not somewhere else.
What ISP do you have and what speed is your connection? I have verizon FIOS and i have 25Mb/s upload and download and notice few or no delays when clicking on a DD link. And any delay i do experience is no ore then 10 seconds.
__________________
1920x1080, R7 260 1GB GDDR5, 16GB 2400Mhz DDR3, AMD A10-7850k @4.4Ghz, 480GB SSD, 240GB SSD, Windows 8.1
mnewsham is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.