PDA

View Full Version : Filezilla Server - Need help with setup


ColemontHD
11-22-2006, 11:29 AM
Ok guys. I downloaded and installed Filezilla Server and followed the steps shown here:
http://www.pcmech.com/byos/step/8/

I started a server using 127.0.0.1 with port 14147 just like the instructions said. The server is up, I go to ftp.myipaddress.com and it doesnt work. I am on a linksys router with a 1mb connection upload. Can you guys help me with the steps to make this work?

skace
11-22-2006, 11:30 AM
What are you using to go to ftp.myipaddress.com. Because that is not correct.

You need to go to ftp://youripaddress:14147

I assume you also setup an account with certain privelages / a home directory too.

ColemontHD
11-22-2006, 11:34 AM
Ok. I typed that in and still nothing. The computer IP address from the router to the computer is 192.168.1.101. I went in, added that and the port to the router to allow it to go through. Still nothing.

mundane
11-22-2006, 11:38 AM
You might be having a software firewall issue. Check whatever firewall you have running on your server machine and permit port 14147. You won't need to deal with forwarding from the router until accessing from outside of your network.

skace
11-22-2006, 11:38 AM
Ok so you are behind a firewall too? And you allowed 14147 to route to 192.168.1.101?

Now.. when I said ftp://youripaddress:14147 did you put in that local ip address or did you put in your global ISP ip address?

ColemontHD
11-22-2006, 11:39 AM
Well, that is what I am trying to do. I am trying to setup a ftp server to access from work, friends place and what not. Firewall is not on.

ColemontHD
11-22-2006, 11:40 AM
Originally posted by: skace
Ok so you are behind a firewall too? And you allowed 14147 to route to 192.168.1.101?

Now.. when I said ftp://youripaddress:14147 did you put in that local ip address or did you put in your global ISP ip address?

ISP address. I am trying to access it from outside the network.

ColemontHD
11-22-2006, 11:40 AM
Do I need to turn on DMZ?

ColemontHD
11-22-2006, 11:42 AM
If anyone can get on MSN and contact me at ColemontHD@gmail.com I would be greatly appreciative.

ColemontHD
11-22-2006, 11:43 AM
Double post, sorry.

skace
11-22-2006, 11:58 AM
Sorry, don't have MSN and couldn't use it where I currently am anyhow. Turning on DMZ saves troubleshooting port forwarding. But I am not sure that the FTP server is setup properly yet.

Since you are behind a NAT router, you will most likely have to manually enter your PASV information into the program. Your PASV information being your global ISP IP. Also, on the console of your home machine, are you seeing connections even hit it, or nothing.

ColemontHD
11-22-2006, 12:01 PM
PASV?

skace
11-22-2006, 12:07 PM
Just go into the filezilla options and I'm sure you will see it mentioned. Basically, when an outside machine connects to you, your machine responds back with an IP address, by default it is the machines IP address. So sometimes you have to manually modify it so that it sends back your outside IP address.

Aikouka
11-22-2006, 12:11 PM
Does this work if you try to access it from another PC on your network? In this case, you'd use the internal IP

ftp://192.168.1.101:14147

Also, if your router supports it! sign up for DynDNS.org and get a free url that'll forward to your connection. Your router doesn't need to support it, but if it does, that means your router can connect to DynDNS.org and update the IP address automatically. This is a free service, but they do have paid services as well, so it can be kind of hard to find it on their webpage.

n0cmonkey
11-22-2006, 01:06 PM
Originally posted by: ColemontHD
Ok guys. I downloaded and installed Filezilla Server and followed the steps shown here:
http://www.pcmech.com/byos/step/8/

I started a server using 127.0.0.1 with port 14147 just like the instructions said. The server is up, I go to ftp.myipaddress.com and it doesnt work. I am on a linksys router with a 1mb connection upload. Can you guys help me with the steps to make this work?

Try it on the machine that is running Filezilla. The address you are using (127.0.0.1) is a loopback address. It's for applications on a machine to talk to other applications on the same machine.

If you want to provide access to people outside of that machine, you will need to set it to the IP address of the computer filezilla is running on (192.168.1.101 - which is probably a dhcp address, so unless you only have 1 machine using dhcp it may change).

Try it on the local machine first. Then change the IP address it binds to to the 192.168 address and try it from a second machine on the same network (behind the router). Lastly, try it from a machine outside of your network (get a friend to help if you have to).

EDIT: Ok, that seems retarded. The 127.0.0.1:14147 thing is for admin purposes. 14147 does not appear to be the port you need to connect to to access the server.

In the filezilla settings:
General settings: Listen on these ports: 21 is default, if you haven't changed this then you're fine. If you have, it's easy to work with.
IP bindings: My fresh install has "*", so my above assumptions were definitely wrong. Bummer.
Passive mode settings: Someone else mentioned PASV, this is where you would fiddle with that.

My original troubleshooting is still mostly applicable.
ftp to your machine from that machine
ftp to the filezilla machine from another machine on the local lan
Make sure the correct ports are forwarded from the SOHO NAT box
Try to ftp into the system from a machine external to your lan

Sounds like it'd be about the right order too.

imported_Ned Flanders
11-22-2006, 01:17 PM
From inside your network, it will mess up if you try and go 'out' onto the internet, then back 'in' to the server. Get a friend to test it for you